この記事では、ユーザー ディレクトリ、ユーザー プロファイル、または ProgramData ディレクトリが既定の場所から移動された後に Microsoft Store Apps を起動できない問題の解決策について説明します。
適用対象: Windows 10 - すべてのエディション
元の KB 番号: 2787623
現象
Users ディレクトリ、個々のユーザー プロファイル、または ProgramData ディレクトリを既定の場所から移動すると、Microsoft Store Apps は起動しなくなります。 様々な症状が気づくかもしれません. 表示される可能性のある症状の一部を次に示します。
Microsoft Store アプリまたは Microsoft Store のタイルをクリックすると、アプリの起動が開始されますが、スタート画面に戻ります。 エラーは表示されません。
Microsoft Store のタイルをクリックすると、ストアが開き、エラーが返されます。
ストアに接続できませんでした。 これは、サーバーの問題またはネットワーク接続がタイムアウトしたために発生した可能性があります。数分待ってから、もう一度やり直してください。 [再試行] をクリックすると、ストアへの接続に成功する場合と失敗する場合があります。
Microsoft Store のタイルをクリックするとストアが開きますが、アプリを購入しようとするとエラーが返されます。
購入を完了できませんでした
最新の PC 設定アプリは開かないため、そこからアクセスされたアプリも開かなくなります。
最新の Windows Update は開かないが、コントロール パネル経由でアクセスされるレガシ Windows Update は開かない。
原因
Users ディレクトリ、個々のユーザー プロファイル、または ProgramData ディレクトリが既定の場所以外の別の場所に移動されると、Microsoft Store Apps はサポートされなくなり、動作することが期待されます。
解決方法
USERS ディレクトリ (既定では c:\users) または個々のユーザー プロファイルの既定の場所を変更しないでください。 ProgramData ディレクトリの既定の場所を変更しないでください (既定では c:\ProgramData)
詳細
Users ディレクトリと ProgramData ディレクトリを再配置する方法の詳細については、以下のリンクを参照してください。 これらのメソッドは現状のまま提供され、テスト環境のみを対象としています。 これらのメソッドは、Microsoft Store アプリと Microsoft Store アプリが使用されている場合はサポートされていないことを明確に示しています。