この記事では、DisplayPort または HDMI モニターを使用するシステムであるソースのオーディオの再生が失敗する問題の解決策を示します。
適用対象: Windows 10 バージョン 2004、Windows 10、バージョン 1909、Windows 10、バージョン 1809、Windows 10、バージョン 1803、Windows 10、バージョン 1709
元の KB 番号: 2841997
現象
以下のシナリオについて考えてみます。
- 統合オーディオが接続されている DisplayPort または HDMI モニターを備えた Windows 10 ベースまたは Windows 8 ベースのコンピューターがある。 または、DisplayPort オーディオを使用するオールインワン システムがあります。
- Xbox Music アプリ、Windows メディア プレーヤー、Groove Music、または Movies & TV を使用してオーディオを再生しており、オーディオ ソースがモニターです。
- オーディオの再生中は、システムをスリープ状態にします。 次に、システムを起動します。
このシナリオでは、Windows 8 の Xbox Music アプリで次のエラー メッセージが表示されることがあります。
再生できません。 コンピュータのサウンドカードとビデオカードが動作していて、最新のドライバがあることを確認してから、もう一度やり直してください。
0xc00d11d1 (0xc00d4e86)
または、Windows 10 および Windows 8 のWindows メディア プレーヤーで次のエラー メッセージが表示される場合があります。
オーディオ デバイスが切断または再構成されました。 オーディオ デバイスが接続されていることを確認し、もう一度項目の再生を試みます。
この問題は、Windows 10 で Groove Music and Movies & TV アプリを使用する場合にも発生します。 問題が発生すると、次のエラー メッセージが 1 つ以上表示されます。
Groove Music (オーディオ ファイル)
再生できません。 ヘッドホンまたはスピーカーが接続されているオーディオ デバイスが見つかりませんでしたか? そうでない場合は、デスクトップに移動し、システム トレイのスピーカー アイコンをタップして詳細を確認できます。 0xc00d4e86 (0xc00d4e86)
映画 & テレビ (ビデオ ファイル)
再生できません。 ヘッドホンまたはスピーカーが接続されているオーディオ デバイスが見つかりませんでしたか? そうでない場合は、デスクトップに移動し、システム トレイのスピーカー アイコンをタップして詳細を確認できます。 0xc00d4e86 (0xc00d4e86)
原因
この動作は仕様です。 他のオーディオ デバイスがシステムに接続されていない場合、モニターの電源がオフになると、システム上の唯一のオーディオ エンドポイントは停止します。 そのため、Xbox Music、Windows メディア プレーヤー、Groove Music、または Movies > TV によってエラー メッセージが表示されます。 エラー メッセージは、特定の DisplayPort または HDMI モニターにのみ表示され、別のオーディオ出力デバイスがシステムに接続されている場合は発生しません。
解決方法
別のオーディオ出力デバイスがシステムに接続されている場合、Xbox Music、Windows メディア プレーヤー、Groove Music、または Movies > TV は、モニターの電源がオフのときにそのオーディオ デバイスに切り替わり、モニターの電源がオンになったときにモニターに戻ります。 エラー メッセージは表示されません。
モニターの電源がオフのときに他のオーディオ デバイスがシステムに接続されていない場合に再生を再開するには、エラー メッセージが表示された後に別のオーディオ ファイルを開くか、元のオーディオ ファイルを再度開く必要があります。