コーデック エラー メッセージが表示されるか、オーディオが再生されますが、Windows メディア プレーヤー 11 でメディア ファイルを再生してもビデオが再生されない

この記事では、Windows メディア プレーヤー 11 でビデオを再生するときにビデオが再生されない問題の解決策について説明します。

適用対象: Windows メディア プレーヤー 11
元の KB 番号: 926373

現象

Windows メディア プレーヤー 11 でビデオ ファイルを再生しようとすると、ビデオは再生されません。 ただし、オーディオは再生されます。

さらに、Windows メディア プレーヤー 11 でオーディオ ファイルまたはビデオ ファイルを再生しようとすると、次のいずれかのエラー メッセージのようなエラー メッセージが表示される場合があります。

Windows メディア プレーヤー必要なビデオ コーデックがコンピューターにインストールされていないため、ファイルを再生できません。

Windows メディア プレーヤーは、必要なオーディオ コーデックがコンピューターにインストールされていないため、ファイルを再生、書き込み、リッピング、または同期できません。

このファイルを再生するにはコーデックが必要です。 このコーデックを Web からダウンロードできるかどうかを判断するには、[Web ヘルプ] をクリックします。

ファイル形式が無効です。

原因

この問題は、ファイルの再生に必要なコーデックがコンピューターにインストールされていない場合に発生します。

解決方法

この問題を解決するには、コーデックを自動的にダウンロードするようにWindows メディア プレーヤーを構成します。 これを行うには、Windows メディア プレーヤー 11 の次の手順に従います。

  1. [ツール] メニューの [オプション] を選択します。
  2. [プレーヤー] タブを選択し、[コーデックを自動的にチェックダウンロードする] ボックスを選択し、[OK] を選択します
  3. ファイルを再生してみてください。

コーデックのインストールを求められたら、[インストール] を選択 します。 それでもファイルを正しく再生できない場合は、「 高度なトラブルシューティング 」セクションの手順を試してください。 高度なトラブルシューティングに慣れていない場合は、他のユーザーにヘルプを依頼するか、Microsoft サポートにお問い合わせください。

高度なトラブルシューティング

次の手順は、高度なコンピューター ユーザーを対象としています。

Windows メディア プレーヤー 11 の次の手順に従ってコーデックを取得してインストールします。

  1. ファイルの再生に使用しているコンピューターにコーデックがインストールされているかどうかを確認します。 そのために、以下の手順に従ってください。

    1. [ 今すぐ再生 中] 領域で、再生するファイルを右クリックし、[ プロパティ] を選択します。
    2. [ ファイル ] タブを選択し、[オーディオ コーデック] と [ビデオ コーデック ] 領域で指定されている コーデック を書き留め、[ OK] を選択します。 次の条件に該当する場合は、手順 2 に進みます。
      • オーディオ コーデックは指定されません。
      • ビデオ コーデックは指定されません。
    3. [ヘルプ] メニューの [Windows メディア プレーヤーについて] を選択します。
    4. [ テクニカル サポート情報 ] ハイパーリンクを選択します。
    5. オーディオ ファイルを再生しようとしている場合は、手順 1b で示したオーディオ コーデックが [オーディオ コーデック ] 領域に一覧表示されているかどうかを確認します。 ビデオ ファイルを再生する場合は、手順 1b で説明したビデオ コーデックまたはオーディオ コーデックが [ビデオ コーデック ] 領域に一覧表示されているかどうかを確認します。 コーデックが一覧にない場合は、手順 2 に進みます。
    6. コーデックを再インストールしてみてください。 コーデックを再インストールできない場合は、手順 2 に進みます。
    7. ファイルを再生してみてください。 ファイルを再生できる場合は、手順 2 と 3 をスキップします。
  2. 次の手順に従ってコーデックをインストールします。

    1. ファイルの再生時にエラー メッセージが表示される場合は、[ Web ヘルプ] を選択します。 ファイルを再生しようとしたときにエラー メッセージが表示されない場合は、手順 3 に進みます。

    2. Microsoft Web サイトで、Wmplugins Web サイトへのリンクを選択します。

    3. Web サイトの指示に従って、ファイルのコーデックをダウンロードしてインストールします。 Web サイトでファイルのコーデックが自動的に見つからない場合、次のいずれかの条件が当てはまる場合は、手順 3 に進みます。

      • 手順 1b でコーデックを書き留めませんでした。
      • Web サイトの手順 1b で示したコーデックが見つかりません。
    4. ファイルを再生してみてください。 ファイルを再生できる場合は、手順 3 をスキップします。

  3. サードパーティベンダーからコーデックを取得します。

注:

ネットワーク管理者によって管理されている環境でWindows メディア プレーヤーを使用している場合は、ネットワーク管理者に連絡してコーデックをダウンロードしてインストールする必要がある場合があります。

詳細

このドキュメントは暫定版であり、このドキュメントに記載されている情報およびソリューションは、このドキュメントの発行日におけるマイクロソフトの見解を示すものです。 これらのソリューションはマイクロソフトまたはサードパーティ プロバイダーを通じて利用できます。 Microsoft では、この記事で説明する可能性があるサード パーティのプロバイダーまたはサード パーティのソリューションを特に推奨していません。 また、この記事では説明していない他のサード パーティ プロバイダーやサード パーティのソリューションも存在する可能性があります。 Microsoft は市場の状況の変化に対応する必要があるため、この情報を Microsoft によるコミットメントと解釈しないでください。 Microsoft は、Microsoft が提供する情報またはソリューションの正確性、または前述のサード パーティ プロバイダーによる正確性を保証または保証することはできません。

明示、黙示、または法律の規定にかかわらず、マイクロソフトは一切の保証をせず、すべての表示、保証、および条件を排除します。 これには、サービス、ソリューション、製品、またはその他の素材または情報に関して、タイトルの表明、保証、または条件、非侵害、満足のいく条件、商品性、および特定の目的への適合性が含まれますが、これらに限定されません。 マイクロソフトは、いかなる場合においても、この資料に記載されているサードパーティ ソリューションの責任を負いません。