次の方法で共有


Windows ストア アプリが開かない可能性があり、イベント ID 5973 がアプリケーション ログに記録される

この記事では、Windows ストア アプリを開くことができないときにログに記録されるイベント ID 5973 を修正するソリューションを提供します。

適用対象: Windows 8.1
元の KB 番号: 3064045

現象

Windows 8.1 を実行しているデバイスでは、すべての Windows ストア アプリが開かず、次のようなエラーがアプリケーション ログに記録されます。

ログ名: Application
ソース: Microsoft-Windows-Immersive-Shell
日付: 日付と時刻
イベント ID: 5973
タスク カテゴリ: (5973)
レベル: エラー
キーワード:
ユーザー: ユーザー ID
コンピューター: コンピューター名
説明:
アプリ AppID のアクティブ化がエラーで失敗しました:このアプリは、指定されたコントラクトをサポートしていないか、インストールされていません。 詳細については、Microsoft-Windows-TWinUI/Operational ログを参照してください。

原因

異常なシャットダウンにより、 C:\Users\<username>\AppData\Local\Packagesのユーザー アプリケーション キャッシュが破損する可能性があります。

解決方法

問題があるかどうかをテストするには、新しいユーザー アカウントを作成新しいアカウントにサインインします。 問題が解決しない場合は、ユーザー プロファイルを再作成して問題を解決します。

  1. 古いユーザー アカウントのユーザー プロファイル データ ファイルをバックアップします。

    • 画面の右端からスワイプし、 [検索] をタップします。 (マウスを使用している場合は、画面の右下隅をポイントし、マウス ポインターを上に移動して、[ 検索.)

    • [ 検索 ボックスに、「非表示のファイルとフォルダー 表示」と入力し Enter キーを押します。

    • [ Folder のオプション ] ダイアログの [ View ] タブで、[ Advanced 設定を確認し、次の設定を設定します。

      • 非表示のファイル、フォルダー、ドライブを表示 ボタンを選択する必要があります。
      • 既知のファイルの種類の拡張子を非表示にする はオフにする必要があります。
      • 保護されたオペレーティング システム ファイルを非表示にする (推奨) はオフにする必要があります。
    • エクスプローラーで、C:\Users\Old_Username フォルダーを探します。C は Windows がインストールされているドライブで、Old_Usernameはバックアップするプロファイルの名前です。

    • このフォルダー内のすべてのファイルとフォルダーを選択してコピーします。次のファイルが必要です。

      • NtUser.dat
      • NtUser.ini
      • NtUser.log (または存在しない場合は、ntuser.dat.log1 と ntuser.dat.log2 という 2 つのログ ファイルを除外します)
    • 選択したバックアップ場所にファイルを貼り付けます。 必要に応じて、このバックアップ場所から古いユーザー アカウント プロファイルを取得できますが、 C:\Users\<Old_Username>\AppData\Local\Packages のファイルが破損している可能性があり、他のファイルも破損している可能性があることに注意してください。

  2. 古いユーザー アカウントからサインアウトします。 電子メール プログラムに電子メール メッセージがある場合は、古いプロファイルを削除する前に、新しいユーザー プロファイルに電子メール メッセージとアドレスをインポートする必要があります。 すべてが正常に動作している場合は、古いプロファイルを削除できます。