次の方法で共有


OneDrive for Business がインストールされている Windows では、%username% を使用できません

この記事では、OneDrive for Business がインストールされている Windows で %username% が使用できない問題の解決策を示します。

適用対象: Windows 10 - すべてのエディション
元の KB 番号: 4551435

現象

OneDrive for Business がインストールされている Windows インストールでは、 %username% 変数は断続的に使用できません。 これにより、ユーザー エクスペリエンス仮想化 (UE-V) など、この変数に依存するアプリケーションが正しく動作しません。

原因

場合によっては、OneDrive for Business は、ユーザーがログオンした直後に Windows エクスプローラー プロセスを再起動します。 この場合、 %username% 変数は新しいエクスプローラー プロセスによって継承されません。 "Settings Storage" 設定の一部として %username% 変数を使用して UE-V をデプロイした場合、リテラル文字列が使用されます。 そのため、すべてのユーザー アカウントが同じフォルダーに書き込まれます。 これにより、ネットワーク共有をホストするサーバーで CPU アクティビティが高くなる可能性があります。

解決方法

警告

レジストリ エディタや他の方法を使用してレジストリを変更する際、適切に変更しないと重大な問題を引き起こす可能性があります。 場合によっては、オペレーティング システムの再インストールが必要になります。 こうした問題の修復について、マイクロソフトはいかなる保証もいたしません。 レジストリはユーザー自身の責任において変更してください。

この問題を解決するには、次のレジストリ キーのいずれかまたは両方を有効にして、OneDrive がエクスプローラーを再起動しないようにします。

ユーザーごとの OneDrive のインストール

HKEY_CURRENT_USER\SOFTWARE\Microsoft\OneDrive
"HasSystrayIconBeenPromoted"=dword:00000001

コンピューターごとの OneDrive のインストール

  • 32 ビット バージョンの OneDrive の場合:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\OneDrive
    "HasPerMachineSystrayIconBeenPromoted"=dword:00000001

  • 64 ビット バージョンの OneDrive の場合:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\OneDrive
    "HasAMD64PerMachineSystrayIconBeenPromoted"=dword:00000001