この記事では、回復不可能なエラーが発生したときに TPM デバイス ドライバーがシステム ログに記録される問題について説明します。
適用対象: Windows 10 – すべてのエディション
元の KB 番号: 4562894
現象
TPM デバイスでは、BitLocker に関する問題、先進認証または次世代資格情報を使用したアプリケーションへのログ記録が発生します。 これらのメッセージはイベント ログに記録されます。
- トラステッド プラットフォーム モジュール (TPM) ハードウェアで TPM コマンドを実行できませんでした。
- トラステッド プラットフォーム モジュール (TPM) のデバイス ドライバーで、TPM ハードウェアで回復不可能なエラーが発生したため、TPM サービス (データ暗号化など) が使用されません。
詳細については、次のログ例を参照してください。
イベント ID 14
ログ名: システム
ソース: TPM
日付:
イベント ID: 14
タスク カテゴリ: なし
レベル: エラー
キーワード:
ユーザー: SYSTEM
コンピューター:WIN10PC.CONTOSO.COM
説明:
トラステッド プラットフォーム モジュール (TPM) のデバイス ドライバーで、TPM ハードウェアで回復不可能なエラーが発生したため、TPM サービス (データ暗号化など) が使用されません。 詳細については、コンピューターの製造元にお問い合わせください。
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event
">
<システム>
<Provider Name="TPM">
<EventID>14</EventID>
<バージョン>0</バージョン>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<EventRecordID>55474</EventRecordID>
<相関/>
<Execution ProcessID="4" ThreadID="284" />
<Channel>System
<Computer>WIN10PC.CONTOSO.COM</Computer>
<Security UserID="S-1-5-18" />
</制>
<EventData>
<Data Name="locationCode">0x2c000230</Data>
<Data Name="Data">255</Data>
</EventData>
</出来事>
イベント ID 17
ログ名: システム
ソース: TPM
日付:
イベント ID: 17
タスク カテゴリ: なし
レベル: Information
キーワード:
ユーザー: SYSTEM
コンピューター:WIN10PC.CONTOSO.COM
説明:
トラステッド プラットフォーム モジュール (TPM) ハードウェアで TPM コマンドを実行できませんでした。
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event
">
<システム>
<Provider Name="TPM">
<EventID>17</EventID>
<バージョン>0</バージョン>
<Level>4</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8000000000000000</Keywords>
<EventRecordID>55475</EventRecordID>
<相関/>
<Execution ProcessID="4" ThreadID="284" />
<Channel>System</Channel>
<Computer>WIN10PC.CONTOSO.COM</Computer>
<Security UserID="S-1-5-18" />
</制>
<EventData>
<Data Name="locationCode">0x1e000354</Data>
<Data Name="TpmCommandOrdinal">378</Data>
<Data Name="TpmResponseCode">3221225860</Data>
</EventData>
</出来事>
原因
この問題は、TPM デバイスに問題があるために発生します。 これにより、次のような TPM で応答する機能に対して、Windows が TPM デバイスを通信および使用できなくなります。
- BitLocker
- 先進認証
- 次世代資格情報
回避策
次の更新プログラムがインストールされていることを確認します。
- Windows での最新のサービス スタック更新プログラム (SSU) および月 単位の累積的な更新プログラム (CU)
- 製造元のサポート Web サイトで BIOS ファームウェアまたは TPM デバイス ファームウェアを更新できます。
問題が解決しない場合は、ハードウェア ベンダーまたはデバイスの製造元に問い合わせて、TPM デバイスを診断してください。 詳細については、「 TPM 推奨事項」を参照してください。