この記事は、Windows Embedded for Point of Service でヒューマン インターフェイス デバイス アクセス サービスまたは HID 入力サービスの起動に失敗する問題を解決するのに役立ちます。
オリジナル製品バージョン: ヒューマンインターフェイスデバイスアクセスサービス、HID入力サービス
元の KB 番号: 2009753
現象
Windows Embedded for Point of Service でヒューマン インターフェイス デバイス アクセス サービスまたは HID 入力サービスの起動に失敗すると、SCM ID 7023 エラーがイベント ログに表示されます。
この不足しているサービスは、Windows Embedded for Point of Service がデバイスを列挙できない原因Bluetooth考えられます。 また、スキャナー、磁気ストリップ リーダー、HID 入力サービスに依存する他の周辺機器など、一般的な POS HID デバイスが Windows Embedded for Point of Service システムに接続できない場合もあります。
原因
Windows Embedded for Point of Service のインストール中に HID デバイスが接続されていない場合、HIDSERV.DLL ファイルがシステムにインストールされず、HID サービスが開始されない可能性があります。 HID デバイスが後で Windows Embedded for Point of Service システムに追加された場合、または HID サービスに依存するその他の機能が必要な場合は、HID サービスの障害によって動作が妨けられます。
解決方法
HID 入力サービスまたは基になるBluetoothの依存関係が、Windows Embedded for Point of Service システムの要件でない場合は、サービスを無効にして、イベント ログでエラー報告をクリアできます。
HID 入力サービスが必要な場合は、次の手順に従って不足しているファイルをインストールしてサービスを開始します。
%systemroot%\i386
フォルダーを参照します。- sp2.cab ファイルをダブルクリックすると、.cab ファイル内の圧縮ファイルが一覧表示されます。
- hidserv.dll ファイルを
%systemroot%\system32
フォルダーにコピーします。 - HID 入力サービスを再起動するか、コンピューターを再起動します。