次の方法で共有


WINDOWS Embedded POSReady 2009 で MS ソフトウェア シャドウ コピー プロバイダー サービスが開始されない

この記事は、Microsoft ボリューム コピー サービス プロバイダーがサービスの一覧に存在しない問題を解決するのに役立ちます。

元の製品バージョン: Windows Embedded POSReady 2009
元の KB 番号: 2519872

現象

複数の症状が発生する可能性があります。

  • Norton Ghost などのアプリケーションは実行できません。
  • デフラグを実行すると、エラー コード 12292 がアプリケーション イベント ログに書き込まれます。
  • バックアップを実行するたびに、アプリケーション イベント ログでエラーを0x80110401します。

原因

ボリューム コピー サービス プロバイダーは、サービスの一覧に表示されません。 これは、正しく登録されておらず、起動に失敗するためです。

解決方法

この問題を解決するには、コマンド プロンプトまたはコマンド スクリプトで次のコマンドを実行し、システムを再起動して変更を反映させます。

cd /d %windir%\system32
Net stop vss
Net stop swprv
regsvr32 /s ole32.dll
regsvr32 /s oleaut32.dll
regsvr32 /s vss_ps.dll
vssvc /register
regsvr32 /s /i swprv.dll
regsvr32 /s /i eventcls.dll
regsvr32 /s es.dll
regsvr32 /s stdprov.dll
regsvr32 /s msxml.dll
regsvr32 /s msxml3.dll

詳細

Note

コマンド Net stop swprv は、エラー MS ソフトウェア シャドウ コピー プロバイダー サービスが開始されていないで失敗する可能性があります。 これは、MS ソフトウェア シャドウ コピー プロバイダーがイベント ログ エラーの原因である場合に想定される動作です。 このシーケンスを使用してボリューム シャドウ コピー サービスの他の問題を解決する場合は、サービスを停止する必要があります。