この記事では、ワークグループ コンピューターをドメインに参加させるときに0x54bエラー コードを解決するためのトラブルシューティング手順について説明します。
症状
ワークグループ コンピューターをドメインに参加させると、次のエラー メッセージが表示されます。
エラー コードの0x54b
コンピューター名/ドメインの変更
ドメイン "<NetBIOS\_name>" の Active Directory ドメイン コントローラー (AD DC) に接続できませんでした。
ドメイン名が正しく入力されていることを確認します。
名前が正しい場合は、[詳細] をクリックしてトラブルシューティング情報を確認します。
注: この情報は、ネットワーク管理者を対象としています。 ネットワークの管理者でない場合は、この情報を受信したことを管理者に通知します。この情報は C:\WINDOWS\debug\dcdiag.txt ファイルに記録されています。
ドメイン "<domain_name>" のActive Directory ドメイン コントローラー (AD DC) の検索に使用されるサービスの場所 (SRV) リソース レコードに対して DNS が照会されたときに、次のエラーが発生しました。
エラーが発生しました: "タイムアウト期間が終了したため、操作が返されました"。(エラーコード 0x000005B4 ERROR_TIMEOUT)
クエリは、 <srv_recordの SRV レコード用でした>
このコンピューターで名前解決に使用される DNS サーバーが応答していません。 このコンピューターは、次の IP アドレスを持つ DNS サーバーを使用するように構成されています。
<IPアドレス>このコンピューターがネットワークに接続されていること、これらが正しい DNS サーバーの IP アドレスであり、少なくとも 1 つの DNS サーバーが実行されていることを確認します。
netsetup.log ファイルの例を次に示します。
NetpValidateName: checking to see if '<domain_name>' is valid as type 3 name
NetpCheckDomainNameIsValid for <domain_name> returned 0x54b, last error is 0x0
NetpCheckDomainNameIsValid [ Exists ] for '<domain_name>' returned 0x54b
原因
エラー コード 0x54bは "ERROR_NO_SUCH_DOMAIN" を意味します。このエラー コードは、指定されたドメインに接続できないことを示し、ドメイン コントローラー (DC) の検索に関する問題を示しています。
- ドメイン ネーム システム (DNS) がタイムアウトし、DC に到達しようとすると解決が失敗します。
- DC へのネットワーク接続は、TCP ポート 135、389、445、または RPC 動的ポートでブロックされます。
トラブルシューティングの手順
0x54b エラーを解決するには、次の手順に従います。
手順 1: クライアントと DC の間のネットワーク接続を確認する
サーバー ポート | サービス |
---|---|
TCP 135 | RPC エンドポイント マッパー |
TCP 49152-65535 | RPC 動的ポート |
TCP 445 | 中小企業 |
UDP/TCP 389 | LDAP |
「Active Directory ドメインと信頼のファイアウォールを構成する方法」の必要なポートの一覧を参照してください。
Test-NetConnection
コマンドを使用して、DC 間の接続をテストします。Test-NetConnection <IP\_address\_of\_the\_DC> -Port 389 ComputerName: <computer_name> RemoteAddress: <remote_address> RemotePort: 389 InterfaceAlias: Ethernet 2 SourceAddress: <source_address> TcpTestSucceeded : True
これは、LDAP ポート TCP 389 がクライアントと DC の間で開かれていることを示します。
PortQry コマンド ライン ポート スキャナー バージョン 2.0 を使用して、DC でポート (TCP/UDP) がブロックされているかどうかを識別することもできます。 構文の例を次に示します。
portqry -n <problem_server> -e 135 portqry -n <problem_server> -e 445 portqry -n <problem_server> -e 389 portqry -n <problem_server> -p UDP -e 389 portqry -n <problem_server> -r 49152:65535
ポート クエリ出力の例:
DC 上の TCP ポート 135 への接続がブロックされると、次のメッセージが表示されます。
portqry -n <dc_name> -e 135 Querying target system called: <dc_name> Attempting to resolve name to IP address... Name resolved to <ip_address> querying... TCP port 135 (epmap service):FILTERED
DC 上の TCP ポート 389 への接続に成功すると、次のメッセージが表示されます。
portqry -n <dc_name> -e 389 Querying target system called: <dc_name> Attempting to resolve name to IP address... Name resolved to 192.168.1.2 querying... TCP port 389 (ldap service): LISTENING
問題を再現するときにネットワーク モニタートレースを収集し、必要に応じてネットワーク接続の問題があるかどうかを確認します。
手順 2: 優先 DNS サーバーが正しい DNS サーバーであるかどうかを確認する
手順 3: DC を検出できるかどうかを確認する
nltest /dsgetdc
(DC 検出) を実行して、DC を検出できるかどうかを確認します。 例えば次が挙げられます。
nltest /dsgetdc:<domain_name> /force
DC: \\<dc_address>
Address: \\<dc_address>
Dom Guid: <dom_guid>
Dom Name: <dom_name>
Forest Name: <foreast_name>
Dc Site name: Default-First-site-Name
Our Site Name: Default-First-site-Name
Flags: PDC GC DS LDAP KDC TIMESERV WRITABLE DNS_DC DNS_DOMAIN DNS_FOREST CLOSE_SITE FULL_SECRET WS DS_8 DS_9 DS_10 KEYLIST
The command completed successfully
手順 4: SRV レコードが登録されているかどうかを確認する
最も近い DC で DCDiag /v
を実行し、SRV レコードが登録されているかどうかを確認します。 例えば次が挙げられます。
_ldap._tcp.dc._msdcs.<domain_name>.com.