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"w32tm /resync" が "時刻データが利用できなかったため、コンピューターが再同期されませんでした" で失敗します。

この記事では、 w32tm /resync コマンドを実行して時刻をタイム ソースと同期するときに発生する可能性のあるエラーの解決策をいくつか示します。

適用対象: Windows Server (サポートされているすべてのバージョン)
元の KB 番号: 929276

現象

コンピューターで時刻同期の問題が発生しています。 w32tm /resyncを実行して手動再同期を実行すると、次のエラーが返されます:時刻データが利用できなかったため、コンピューターが再同期しませんでした。

C:\Windows\system32>w32tm /resync /rediscover
Sending resync command to local computer
The computer did not resync because no time data was available

次のイベントが表示される場合もあります。

ログ名: システム
ソース: Microsoft-Windows-Time-Service
日付: 24-04-2019 22:35:55
イベント ID: 129
タスク カテゴリ: なし
レベル: 警告
キーワード:
ユーザー: ローカル サービス
コンピューター: MEM1.fabrikam.com
説明: NtpClient は、検出エラーのため、タイム ソースとして使用するドメイン ピアを設定できませんでした。 15 分後に再試行し、それ以降は再試行間隔を 2 倍にします。 エラーは次のとおりです。エントリが見つかりません。 (0x800706E1)

ログ名: システム
ソース: Microsoft-Windows-Time-Service
日付: 24-04-2019 23:45:32
イベント ID: 134
タスク カテゴリ: なし
レベル: 警告
キーワード:
ユーザー: ローカル サービス
コンピューター: MEM1.fabrikam.com
説明: 'time.windows.com,0x9' の DNS 解決エラーが原因で、NtpClient がタイム ソースとして使用する手動ピアを設定できませんでした。 15 分後に再試行し、それ以降は再試行間隔を 2 倍にします。 エラーは次のとおりです。そのようなホストは不明です。 (0x80072AF9)

原因

通常、このエラーは、クライアントが NTP 要求を送信しても、応答として適切な NTP 応答が取得されない場合に発生します。 これを引き起こす可能性のあるシナリオは複数あります。

シナリオ 1

NTP クライアントが NTP サーバーを見つけることができません。 これは、名前解決 (DNS) が失敗したか、NTPServer レジストリ キーで定義されている名前/IP アドレスのスペルミスが原因である可能性があります。

シナリオ 2

UDP ポート 123 がブロックされています。 これは、ローカルの Windows ファイアウォールまたは Microsoft 以外のファイアウォールにある可能性があります。

シナリオ 3

クライアントが時刻を同期しようとしているターゲット NTP サーバーが NTP サーバーとしてアドバタイズされていません。

Resolution

シナリオ 1 の解決策

  1. NTPServer レジストリ キーで定義されている値のスペルと精度を確認します。 正しい名前または IP アドレスを使用して、お客様に有効なサーバーを確認してもらう。
  2. DNS を確認します。 ターゲット NTP サーバーを解決できる適切な DNS サーバーが定義されていることを確認します。
  3. 名前解決で何が起こっているかを理解するには、ネットワーク トレースを使用します。

最終的に、このシナリオはシナリオ 2 またはシナリオ 3 になる可能性があります。

シナリオ 2 の解決策

ネットワーク トレースを収集して UDP ポート 123 トラフィックを確認します。 これを行うには、キャプチャを開始してから、 w32tm /resync /rediscoverを実行します。

  1. UDP 123 (NTP 要求) パケットが送信されていない場合は、ローカルの Windows ファイアウォールで UDP ポート 123 がブロックされている可能性があります。
  2. UDP ポート 123 (NTP 要求) パケットが送信されていても応答が返されない場合は、Microsoft 以外のファイアウォールで UDP ポート 123 がブロックされている可能性があります。

これが検証され、UDP ポート 123 がブロックされていない場合は、シナリオ 3 を検討してください。

シナリオ 3 の解決策

  1. 顧客がドメイン コントローラー (NT5DS、NTP、AllSync を介して) と同期しようとしている場合は、Windows 時間階層を確認します。 PDC 以降では、ドメイン コントローラーを確認して、それぞれのソースからすべての時間を受信していることを確認します。 w32tm /monitor を使用すると、すべてのドメイン コントローラーの状態をすばやく確認できます。

  2. ドメイン コントローラーがソースから時刻を正しく同期している場合は、 dcdiag /test:Advertisingを実行してドメイン コントローラーがドメイン コントローラーとしてアドバタイズされていることを確認し、確認します。

  3. 最後に、ドメイン コントローラーで、次の w32time レジストリ キーが次のように構成されていることを確認します ( HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W32Time)。

    • すべての DC で: \TimeProviders\NtpServer – Enabled=1
    • PDC: \Config – AnnounceFlags = 5
    • メンバー DC の場合: \Config – AnnounceFlags = 10