この記事では、Windows のインストール時にハード ディスク パーティションの選択またはフォーマットに失敗する問題の解決策を示します。
元の KB 番号: 927520
Note
サービス パックがインストールされていない Windows Vista のサポートは、2010 年 4 月 13 日に終了しました。 Windows のセキュリティ更新プログラムを引き続き受け取る場合は、Windows Vista Service Pack 2 (SP2) を実行していることを確認してください。 詳細については、「 Support が一部のバージョンの Windows で終了する」を参照してください。
重要
ダイナミック ディスクは、次の場合にのみサポートされます。
- Windows Vista Business
- Windows Vista Enterprise
- Windows Vista Ultimate。
- Windows 7 Enterprise
- Windows 7 Professional
- Windows 7 Ultimate
- Windows Server 2008 R2 Datacenter
- Windows Server 2008 R2 Enterprise
- Windows Server 2008 R2 Standard
- Windows Web Server 2008 R2
Windows Vista Home Basic、Windows Vista Home Premium、Windows 7 Home Basic、Windows 7 Starter、Windows 7 Home Premium ではサポートされていません。
例外が 1 つあります。 コンピューターを Windows XP Media Center Edition から Windows Vista Home Premium にアップグレードすると、一部の動的ディスクが処理され、サポートされます。
現象
Windows Vista、Windows 7、または Windows Server 2008 R2 をインストールしようとすると、次の 1 つ以上の現象が発生する可能性があります。
Windows Vista、Windows 7、または Windows Server 2008 R2is をインストールするハード ディスクが一覧に表示されません。
Windows Vista、Windows 7、または Windows Server 2008 R2 をインストールするハード ディスク パーティションを選択することはできません。
ハード ディスク パーティションまたはパーティションをフォーマットすることはできません。
ハード ディスク パーティションの正しいサイズを設定することはできません。
次のエラー メッセージが表示されます。
Windows で、インストールの基準を満たすシステム ボリュームが見つかりません
原因
この問題は、次のいずれかの理由で発生する可能性があります。
- Windows は、大容量記憶装置コントローラーまたは大容量記憶装置ドライバーと互換性がありません。
- 大容量記憶装置コントローラーまたは大容量記憶装置ドライバーが古くなっています。
- Windows Vista、Windows 7、または Windows Server 2008 R2 をインストールするハード ディスクはダイナミック ディスクです。
- コンピューターのデータ ケーブルが緩んでいるか、別のハードウェアの問題が発生しました。
- ハード ディスクまたは Windows ファイル システムが破損しています。
- FAT32 パーティション、または Windows Vista、Windows 7、または Windows Server 2008 R2 と互換性のない別の種類のパーティションを選択しようとしました。
この問題を解決するには、次の 1 つ以上の方法を使用します。
解決策 1: パーティションが Windows と互換性があることを確認する
FAT32 パーティションに Windows をインストールすることはできません。 さらに、Windows で使用するダイナミック ディスクを正しく構成する必要があります。 パーティションが Windows Vista、Windows 7、または Windows Server 2008 R2 と互換性があることを確認するには、次の手順に従います。
単純なボリュームを持つダイナミック ディスクの場合は、Diskpart.exe ユーティリティを使用して、ディスクをアクティブ ディスクとして構成します。 Diskpart.exe ユーティリティの使用方法の詳細については、「 DiskPart コマンド ライン オプションを参照してください。
FAT32 パーティションの場合は、パーティションを再フォーマットするか、Convert.exe コマンドを使用してパーティションを NTFS ファイル システム パーティションに変換します。
Note
パーティションをフォーマットすると、すべてのデータがパーティションから削除されます。 このデータには、パーティション上のすべてのファイルが含まれます。
解決策 2: ハード ディスク コントローラーのドライバーを更新する
Windows Vista Windows 7 または Windows Server 2008 R2 をアップグレードとしてインストールする場合は、ハード ディスク コントローラーのドライバーを最新のドライバーに更新します。
Note
Windows セットアップには、現在のドライバーを新しいオペレーティング システムに移行する機能が用意されています。 そのため、Windows セットアップでは、現在コンピューターにインストールされているドライバーを使用できます。 コンピューターに最新のドライバーがインストールされていない場合は、セットアップ プログラムで古いドライバーが使用される可能性があります。 この場合、互換性の問題が発生する可能性があります。
解決策 3: ハード ディスク コントローラーに適切なドライバーを提供する
Windows のクリーン インストールを実行する場合は、ハード ディスク コントローラーの適切なドライバーを指定する必要があります。 Windows をインストールするディスクを選択するように求められたら、 Load Driver オプションもクリックして選択する必要があります。 Windows セットアップでは、プロセスの残りの部分について説明します。
解決策 4: Setupact.log ファイルを調べて、パーティションがアクティブであることを確認する
次のエラー メッセージが表示された場合は、Setupact.log ファイルを調べてパーティションがアクティブであることを確認します。
Windows で、インストールの基準を満たすシステム ボリュームが見つかりません
Note
- Windows Vista、Windows 7、または Windows Server 2008 R2 をアップグレードとしてインストールする場合、Setupact.log ファイルは Drive:$WINDOWS.~BT\Sources\Panther フォルダーにあります。 ドライブ は、既存の Windows インストールを含むドライブを表します。
- Windows Vista、Windows 7、または Windows Server 2008 R2 のクリーン インストールを実行する場合、Setupact.log ファイルは Drive:$WINDOWS\Sources\Panther フォルダーにあります。 ドライブ は、Windows セットアップ ファイルを含む DVD ドライブを表します。
パーティションがアクティブであることを確認するには、次の手順に従います。
DVD ドライブに DVD を挿入します。
ディスクの選択画面で、Shift キーを押しながら F10 キーを押します。 コマンド プロンプト (CMD) ウィンドウが開きます。
Setupact.log ファイルを見つけるためにディレクトリを変更し、Setupact.log ファイルを開きます。
DumpDiskInformation セクションを見つけます。 このセクションには、パーティション マッピングに関する情報が含まれています。
DumpDiskInformation セクションで、次のようなログ エントリを見つけます。
ディスク [0] パーティション [1] がアクティブパーティションである
次のようなエントリの後にこのログ エントリが表示される場合は、Windows ベースのオペレーティング システムを使用するようにハード ディスクが構成されていない可能性があります。
Unknown
この場合は、Diskpart.exe ユーティリティを使用して、別のパーティションをアクティブとして構成します。
Note
この手順により、サード パーティのオペレーティング システムが起動できなくなります。
コマンド プロンプト ウィンドウを閉じます。
解決策 5: ファームウェアの更新プログラムとシステム BIOS の更新プログラムを確認する
ファームウェアの更新プログラムとシステム BIOS の更新プログラムについては、コンピューターのハードウェアの製造元にお問い合わせください。
解決策 6: システム BIOS がハード ディスクを正しく検出していることを確認する
システム BIOS がハード ディスクを正しく検出したことを確認する方法については、コンピューター ハードウェアの製造元にお問い合わせください。
解決策 7: Chkdsk.exeを使用して問題を確認する
Chkdsk.exe ユーティリティを実行して、ディスクの問題を確認します。 ハードディスクが破損している場合は交換してください。
解決策 8: Diskpart.exeを使用してディスクをクリーンアップし、Windows セットアップを再実行する
このセクションに記載されているすべての方法を試しても問題が解決しない場合は、Diskpart.exe ユーティリティを使用してディスクをクリーンアップしてから、Windows セットアップをもう一度実行します。
Note
この方法は、Windows のクリーン インストールを実行する場合にのみ使用します。 ハード ディスクをクリーニングすると、フォーマットされます。 ハード ディスク上のすべてのパーティションとすべてのデータが完全に削除されます。 ディスクをクリーンアップする前に、ハード ディスク上のファイルをバックアップすることを強くお勧めします。
Diskpart.exe ユーティリティを使用してハード ディスクをクリーンアップするには、次の手順に従います。
- DVD ドライブに DVD を挿入します。
- ディスクの選択画面で、Shift キーを押しながら F10 キーを押します。 コマンド プロンプト ウィンドウが開きます。
- 「 diskpart」と入力し、Enter キーを押して diskpart ツールを開きます。
- 「
list disk
」と入力して、Enter キーを押します。 使用可能なハード ディスクの一覧が表示されます。 - 「
sel disk number
」と入力して、Enter キーを押します。 number は、クリーニングするハード ディスクの数です。 これでハード ディスクが選択されました。 - 「
det disk
」と入力して、Enter キーを押します。 ハード ディスク上のパーティションの一覧が表示されます。 この情報を使用して、正しいディスクが選択されていることを確認します。 - ディスクに必要なデータが含まれていないことを確認し、「
clean all
」と入力し、Enter キーを押してディスクをクリーンアップします。 ディスク上のすべてのパーティションとすべてのデータが完全に削除されます。 exit
入力し、Enter キーを押して diskpart ツールを閉じます。- コマンド プロンプト ウィンドウを閉じます。
- Refresh ボタンをクリックして、disk の選択画面を更新します。 この手順では、ディスクを一覧表示します。
- Windows セットアップを実行して、Windows のクリーン インストールを実行します。