この記事では、Windows のコピーを検証しようとしたときに発生するエラーの解決策を示します。
元の KB 番号: 2715304
現象
Windows のコピーを検証しようとすると、次のようなエラー メッセージが表示されることがあります。
更新プログラムのインストールに失敗しました。 エラー情報: 0x80092026
Windows を検証しようとすると、Windows によって更新プログラム 971033がダウンロードされます。 ただし、Windows が更新プログラムをインストールしようとすると、上記のエラー メッセージが更新プログラムに表示されます。 さらに、コンピューターに更新プログラムKB971033をダウンロードして手動で実行しようとすると、次のエラー メッセージが表示される場合があります。
インストーラーでエラーが発生しました: 0x80092026
ローカル セキュリティ オプションの設定により、暗号化操作が失敗しました。
原因
このエラーは、次のレジストリ サブキーの State 値が正しく設定されていない場合に発生します。 この値は、Internet Explorer のセキュリティ設定 発行元の証明書失効のチェック ダウンロードしたプログラムの署名の Checkに対応します。
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing
State という名前のキーを見つけることができます。 既定では、値は 23c00 に設定されます。
解決方法
この問題を解決するには、レジストリ キーを有効な設定に変更します。次に例を示します。
- State = 0x00023e00 - 発行元の証明書失効のチェック オフ
- 状態 = 0x00023c00 - 発行元の証明書失効のチェック オン
以下のいずれかの方法を使用します。
方法 1: レジストリを編集する
警告
レジストリ エディタの使用を誤ると、オペレーティング システムの再インストールが必要になるような深刻な問題を引き起こす可能性があります。 レジストリ エディターの不適切な使用によって生じた問題については、解決を保証できません。 リスクを理解した上でレジストリ エディターを使用してください。
- レジストリ エディター (regedit.exe) を起動します。
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing
に移動します。- 左側のウィンドウで、状態キーを探し、ダブルクリックして開きます。
- Value データを 23c00 または 23e00 (16 進数) に変更します。
- レジストリ エディターを終了します。
方法 2: reg ファイルを作成する
メモ帳を起動します。
メモ帳に、次の情報を貼り付けます。
Windows Registry Editor Version 5.00 [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing "State"=dword:00023c00
ファイルを.regファイルとして保存します。
手順 3 で保存した.reg ファイルをダブルクリックします。
上記のレジストリの変更では、再起動は必要ありません。 更新プログラムを手動でインストールしてみてください。
Windows を正常に検証できます。
詳細
場合によっては、次の 2 つのレジストリについても、 State 値を更新する必要があります。
HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing
HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing
Note
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing
に対して更新される値は、上記の 2 つのレジストリに対して正確である必要があります。
データ収集
Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。