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Windows Server 2012 R2 で MSFT_NetLbfoTeamNic クラスが呼び出されたときにカーネル イベント ID 2 がログに記録される

この記事では、Windows Server 2012 R2 で MSFT_NetLbfoTeamNic クラスが呼び出されたときにカーネル イベント ID 2 をトリガーする問題の回避策について説明します。

元の KB 番号: 3087042

現象

WINDOWS Server 2012 R2 を NIC チーミング機能と共に使用し、サードパーティの WMI プロバイダーを使用して MSFT_NetLbfoTeamNic WMI クラスを呼び出すと、次のイベントがログに記録されます。

ソース: Kernel-EventTracing/Admin
イベント ID: 2
セッション "" は、次のエラーで開始できませんでした: 0xC0000022

この記事では、NIC チーミングを使用しているときに発生するこの特定のエラーにのみ対処します。 このエラーは、サード パーティの WMI プロバイダーのエラーではありません。 さらに、このイベントは、NIC チーミング WMI プロバイダーに関連しない理由でログに記録される可能性があります。

原因

この問題は、サードパーティの WMI プロバイダーが原因ではありません。 この問題は、将来のバージョンの Windows Server で考慮するために追跡されています。

Windows Server 2012 R2 MSFT_NetLbfoTeamNic WMI クラスは、iNetCfg インターフェイスを使用します。 iNetCfg インターフェイスは、Windows によって自動的に有効になる NetCfgTrace カーネル ログ プロバイダーに関連付けられています。 トレース データは、C:\Windows\inf\netcfgx.0.etl ファイルに自動的に保存されます。 すべての WMI プロバイダーは、WMIPRVSE プロセスのコンテキストで実行され、ネットワーク サービス アカウントで実行されます。 ただし、WMI プロバイダーが MSFT_NetLbfoTeamNic クラスを呼び出す場合、NETWORK SERVICE アカウントには、このファイルにトレース データを書き込む権限がありません。

回避策

「現象」セクションで説明されているシナリオでカーネル イベント ID 2 エラーがトリガーされた場合、エラーは無害であり、無視しても問題ありません。

このエラーがログに記録されないようにするには、管理コマンド プロンプトを開き、次のコマンドを実行します。

Takeown /f c:\windows\inf  
icacls c:\windows\inf /grant "NT AUTHORITY\NETWORK SERVICE":"(OI)(CI)(F)"  
icacls c:\windows\inf\netcfgx.0.etl /grant "NT AUTHORITY\NETWORK SERVICE":F  
icacls c:\windows\inf\netcfgx.1.etl /grant "NT AUTHORITY\NETWORK SERVICE":F

これらのコマンドは、このシナリオでのエラー ログ記録を防ぐために必要なファイルアクセス許可を付与します。

また、C:\Windows\inf の所有者を NT SERVICE\TrustedInstaller アカウント (既定の設定) にリセットすることもできます。 これを行うには、次の手順を実行します。

  1. Windows エクスプローラーで C:\Windows に移動し、 C:\Windows\INF ディレクトリを右クリックし、 Properties を選択します。 [セキュリティ] タブで [詳細設定] をクリックします。

  2. Owner の横にある Change をクリックします。

  3. [ Location] をクリックし、ローカル コンピューターを選択します (ドメインに参加している場合は、上にスクロールする必要がある場合があります)。

  4. [オブジェクト名] に「NT SERVICE\TrustedInstaller」と入力し、[名前の確認を選択し、[OK] をクリック。 最後に、次の例のように、icacls コマンドを実行して、NETWORK SERVICE アカウントが継承用に設定されていることを確認します。

    C:\>icacls c:\windows\inf
    
    C:\Windows\inf NT AUTHORITY\NETWORK SERVICE:(OI)(CI)(F)
    
    [...]