この記事では、Windows パフォーマンス モニターを使用してシステム アクティビティを監視するときに発生するエラーの解決策について説明します。
元の KB 番号: 2916994
現象
以下のシナリオについて考えてみます。
- Windows パフォーマンス モニターを使用して、Windows Server のシステム アクティビティを監視します。
- 次のいずれかの操作を行います。
- テンプレートを使用してデータ コレクター セットを作成します。
- 既定のプロパティまたは別のデータ コレクター セットで構成されているのと同じプロパティを使用して、 Data Manager タブで新しいデータ コレクター セットを構成します。
- 生成されたパフォーマンス モニターログ ファイルは、他のパフォーマンス モニター ファイルと同じフォルダーに保存されます。
このシナリオでは、すべてのパフォーマンス モニター ログと、同じフォルダー内にある他のすべてのファイルとフォルダーが削除されます。
原因
この問題は、パフォーマンス モニターが保存または削除する必要があるファイルを判断できないために発生します。
回避策
この問題を回避するには、次のいずれかのようにします。
- パフォーマンス モニターログ ファイルを別のフォルダーに保存します。
- Data Manager タブでデータ コレクター セットを構成するときに、既定の設定を変更します。たとえば、Minimum の空きディスク領域または Maximum フォルダー設定を変更します。
- テンプレートを使用してデータ コレクター セットを作成しないでください。