この記事では、リモート コンピューターのアプリケーションによってトリガーされる Caps Lock キーの状態の変更がクライアント コンピューターに同期されない問題の解決策を示します。
元の KB 番号: 3120433
現象
リモート デスクトップ セッションでリモート コンピューターに接続するとします。 winword.exeやosk.exeなどのアプリケーションが Caps Lock キーの状態を変更した場合、この変更はクライアント コンピューターに同期されません。
たとえば、リモート デスクトップ セッションで、Microsoft Word を開くときに「 h」と入力し、キーボードを押して CapsLock をオンにし、「 ELLO」と入力すると、単語は hELLO。 次に、Enter キーを押します。 この場合、Word の hELLO は自動的に Hello に修正され、リモート デスクトップ セッションでは Caps Lock がオフになります。 ただし、クライアントの物理キーボードでは、CapsLock ライトはオンのままで、Caps Lock On 状態のままです。 リモート デスクトップ セッション Caps Lock キーの状態と同期されません。
Note
この問題を引き起こす Word 機能は、CAP LOCK キーの誤使用名前が付けられていますAutoCorrect オプション。
Windows Server 2008 R2 ベースのコンピューターへのリモート デスクトップ セッションで、同じ手順を実行すると、クライアントの物理キーボードの Caps Lock キーもオフの状態に変わり、リモート デスクトップ セッションと同期されます。
原因
この問題は、Windows Server 2012 および Windows Server 2012 R2 がリモート デスクトップ キーボード デバイスを使用してリモート デスクトップ セッションでのキーボード入力を処理するため発生します。
解決方法
クライアントとリモート デスクトップ セッション Caps Lock キーをもう一度同期するには、リモート デスクトップ セッション ウィンドウを最小化するか、リモート デスクトップ セッション ウィンドウの外側にあるマウスをクリックしてから、もう一度クリックする必要があります。
Office アプリの場合は、AutoCorrect オプションで cAP LOCK キーを誤って使用を無効にして問題を解決できます。 たとえば、Word 2016 の次の手順に従います。
- Word 2016 を起動し、 FILE を選択し、 Options を選択します。
- [ Proofing を選択します。
- AutoCorrect オプション ボタンを選択します。
- [CAP ロック キーの誤使用を修正するチェック ボックスをオフにします。
- [OK] を選択します。