この記事では、ローカル ドライブのリダイレクトが RDP セッションで動作しない問題の解決策を示します。
適用対象: Windows Server 2003
元の KB 番号: 2436104
現象
リモート デスクトップ プロトコル (RDP) 経由で Windows Server 2003 または Windows Server 2003 R2 ターミナル サーバーに接続すると、次の現象が発生することがあります。
- ローカル ドライブは RDP セッションではリダイレクトされません。
- その他のデバイスとリソースが適切にリダイレクトされる場合があります。
- イベント ビューアーには、ドライブのリダイレクトの失敗に関連するイベントはありません。
確認すべき事項:
サーバー: ターミナル サービスの構成 - Connections - RDP-Tcp - Properties - Client の設定: Drive のマッピング オプションがオフになっていることを確認します 次。
サーバー: ターミナル サービスの構成 - Connections - RDP-Tcp - Properties - Client の設定: [接続] の [ログオン時のクライアント ドライブの接続] が選択されています。
クライアント コンピューター: Start - Run - MSTSC - Options - ローカル リソース - Disk ドライブ が選択されていることを確認します。
マシン上のポリシーの結果セットを確認します。[ターミナル サービス グループ ポリシー]、[
Computer Configuration\Administrative Templates\Windows Components\Terminal Services\Client/Server
データ リダイレクト] の [ドライブリダイレクトを許可しない]: を有効にしないでください。
原因
RDP のネットワーク プロバイダーの値がレジストリに見つからない可能性があります。
解決方法
[ネットワーク プロバイダー] エントリに少なくとも既定のエントリがあることを確認します。
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order - ProviderOrder -
既定のエントリ: RDPNP、LanmanWorkstation、Web クライアント
詳細
これらの変更を行った後、再起動は必要ありません。