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サーバー マネージャーからサーバーを削除した後、リモート デスクトップ サービス ツールが機能しない

この記事では、サーバー マネージャーからサーバーを削除した後にリモート デスクトップ サービス (RDS) ツールが機能しない問題の解決策について説明します。

元の KB 番号: 2910155

現象

Windows Server 2012 環境では、リモート デスクトップ サービス コレクションの一部であったサーバー マネージャー サーバー プールからサーバーを削除します。 ただし、リモート デスクトップ サービスの展開 ([コレクション] ページのサーバーの一覧) からサーバーを削除することはありません。 この状況で [リモート デスクトップ サービス] セクションを選択すると、次の例のようなエラー メッセージが表示されます。

この展開の次のサーバーは、サーバー プールの一部ではありません。
1.[server_name]
サーバーはサーバー プールに追加する必要があります。

原因

サーバーはまだリモート デスクトップ サービスの展開の一部ですが、サーバー マネージャーに登録されなくなりました。

解決方法

サーバーを サーバー マネージャー サーバー プールに戻すことができます。 ただし、サーバーが使用停止になった場合、または完全にオフラインになっている場合は、PowerShell を使用してリモート デスクトップ サービスの展開から削除できます。

展開内のサーバーとその役割の一覧を取得するには、 Get-RDServer コマンドレットを使用します。 サーバー名を、エラー メッセージに一覧表示されているサーバー名と一致させます。 また、 Get-RDServerの出力に記載されているロールにも注意してください。 次に、 Remove-RDServer コマンドレットを使用して、デプロイからサーバーを削除します。

例:

PS C:\> Get-RDServer

Server Roles
------ -----
rdhost1.contoso.com {RDS-RD-SERVER, RDS-CONNECTION-BROKER, RDS-WEB-ACCESS}
rdhost2.contoso.com {RDS-RD-SERVER}
PS C:\> Remove-RDServer rdhost2.contoso.com RDS-RD-SERVER

このプロセスが完了したら、サーバー マネージャー再起動します。 [リモート デスクトップ サービス] セクションが再び機能している必要があります。

詳細

Windows PowerShell のリモート デスクトップ コマンドレットの詳細については、「 RemoteDesktopを参照してください。