この記事は、VMware でホストされている仮想マシンにドライバーをインストールできない問題を解決するのに役立ちます。 この問題は、[サービスがデスクトップと対話することを許可する] チェック ボックスをオンにしない場合に発生します。
適用対象: Windows Server 2008 R2 Service Pack 1
元の KB 番号: 3025586
現象
次の条件に該当する場合、VMware の仮想マシンはドライバーを正常にインストールまたは更新しません。
- Telnet Server サービスは、Windows Server 2008 R2 Service Pack 1 (SP1) を実行しており、VMware vSphere がインストールされているコンピューターにインストールします。
- Telnet サーバー サービスは、Services Microsoft 管理コンソール (MMC) で手動または自動で開始するように構成します。 さらに、ローカル システム アカウントを使用してログオンするように Telnet サーバー サービスを変更し、[サービスがデスクトップと対話することを許可する] チェック ボックスをオフにします。
仮想マシンのデバイス マネージャーにドライバーをインストールしようとすると、失敗し、次のエラー メッセージが表示されます。
Windows でデバイスのドライバー ソフトウェアが見つかりましたが、インストール中にエラーが発生しました。
さらに、%windir%/inf フォルダーにあるsetupapi.dev.log ファイルには、次のようなログが記録されます。
dvi: {プラグ アンド プレイ Service: Device Install for PCI\VEN_15AD&DEV_07B0&SUBSYS_07B015AD&REV_01\FF565000B37984FE00}
ump: インストール プロセスの作成: DrvInst.exe <DateTime>
ump: コード 0xc0000142 <DateTime で終了したサーバー インストール プロセス>
ump: {プラグ アンド プレイ Service: Device Install exit(c0000142)}
ndv: 新しいデバイスのデバイスのインストールに失敗しました...NULL ドライバーのインストール。
dvi: {プラグ アンド プレイ Service: Device Install for PCI\VEN_15AD&DEV_07B0&SUBSYS_07B015AD&REV_01\FF565000B37984FE00}
原因
この問題は、セキュリティ上の理由から発生します。 Telnet サーバー サービスは、初期化中に実行されているウィンドウ ステーションにアクセス許可を変更します。 デスクトップと対話する機能を持たないローカル システム アカウントを使用して実行するように Telnet Server サービスを構成すると、別のウィンドウ ステーションで開始されます。 これにより、ローカル システム アカウントでも実行され、デスクトップと対話しない他のプロセスで問題が発生する可能性があります。 そのようなプロセスの 1 つは、新しいデバイス ドライバーのインストール中に使用されるドライバーのインストール プロセスです。
回避策
この問題を回避するには、ローカル システム アカウントで実行するように Telnet サーバー サービスを変更しないでください。 Telnet サーバー サービスは、既定のローカル サービス アカウントで実行したままにすることをお勧めします。
それでも問題が解決しない場合は、最新バージョンの VMWare Tools がインストールされていることを確認できます。 VMWare Tools を更新したりアンインストールしたりできない場合は、次の手順に従います。
VMWare Tools の最新バージョンのセットアップ ファイルを取得します。
[開始] をクリック、[実行] をクリックし、「cmd」と入力して、[OK] をクリック。 コマンド プロンプト ウィンドウが開きます。
VMware Tools セットアップ ファイルがある CD-ROM ドライブにドライブを変更します (例: D:\)。
「setup /c」と入力し、Enter キーを押してすべてのレジストリ エントリを強制的に削除し、古いバージョンの VMware Tools を削除します。
Note
64 ビットのゲスト オペレーティング システムの場合は、「setup64 /c」と入力します。
以前のバージョンの VMware Tools は削除する必要があります。
最新バージョンの VMware Tools をインストールし、Telnet サーバー サービスのログオン設定の設定が正しく設定されていることを確認した後、再起動を実行します。
データ コレクション
Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。
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