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タスク スケジューラ使用時の "アクセス拒否" エラー

タスク スケジューラを使用すると、次のエラー メッセージが表示されます。

アクセスは拒否されます。 ユーザー アカウントには、このタスクを実行するためのアクセス許可がありません。

原因

この問題は、次のいずれかの理由で発生します。

  • タスクの実行に使用したユーザー アカウントに、必要な管理特権がありません。
  • C:\Windows\System32\Tasks フォルダーのアクセス許可が変更されました。
  • タスクは、現在のユーザー アカウントとは異なる特定の資格情報セットで実行するように構成されています。

注:

タスク スケジューラ スナップインで mmc.exe を使用してリモート ホストに接続するか、通常のアカウントを使用して taskschd.msc コンソールに接続すると、アクセス拒否エラーが発生することが予想されます。 システムをリモートで管理できるのは、ローカル管理者グループまたはドメイン管理者グループの一部であるアカウントのみです。 セキュリティ上の理由から、管理者以外のユーザーは、別のユーザーによって作成された Windows タスク スケジューラ タスクを表示または管理できません。 詳細については、「タスク スケジューラの新機能を参照してください。

Resolution

この問題を解決するには、以下のいずれかの手順を実行します。

タスク スケジューラを管理者として実行する

タスク スケジューラ 右クリックし 管理者として実行 選択。 この方法では、多くの場合、アクセスの問題を解決できます。

ユーザー アカウントのアクセス許可を確認する

使用しているユーザー アカウントに、タスクを実行するために必要なアクセス許可があることを確認します。 管理者グループにユーザー アカウントを追加することが必要な場合があります。

タスクのプロパティを変更する

  1. Task Schedulerを開き、問題の原因となっているタスクを見つけて右クリックし、Properties を選択します。
  2. General タブに移動し、[最高の特権で実行] を選択

グループ ポリシーの設定を確認する

  1. Run ボックスに「gpedit.msc」と入力して、グループ ポリシー エディターを開きます。
  2. Computer 構成>Windows 設定>セキュリティ設定>ローカル ポリシー>ユーザー権利の割り当てに移動します。
  3. ユーザー アカウントにバッチ ジョブとして Log が有効になっていることを確認します 適切です。

手動タスクの再初期化

  1. 問題のあるタスクを削除する前に XML ファイルにエクスポートします。 これを行うには、次のコマンドを実行します。

    Export-ScheduledTask -TaskName "<task_name>" -FilePath "<backup_xml_file_path>"
    
  2. レジストリ/ファイルの修正後にタスクを再インポートします。

    Register-ScheduledTask -Xml (Get-Content "<backup_xml_file_path>" | Out-String) -TaskName "<task_name>"