この記事では、システムにサインインできない問題と、ユーザー名とパスワードの入力を繰り返し求められる問題について説明します。
適用対象: サポートされているバージョンの Windows Server
元の KB 番号: 555648
現象
Windows にログオンしようとすると、Windows がログオンしてすぐにログオフします。 ユーザー名とパスワードを入力すると、もう一度 ユーザー名 と Password ダイアログ ボックスが表示されます。 あなたは一生懸命入ろうとしますが、役に立ちません。
原因
標準モードまたはセーフ モードを使用してシステムにログオンすることはできません。 これは、Winlogon サービスが Windows の既定のシェル (explorer.exe) とユーザー シェル (userinit.exe) をレジストリから読み込もうとする場合にのみ発生します。 このサービスは、レジストリの次のパスでExplorer.exeとUserinit.exeを検索します。
HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
解決方法
これらの値を編集し、シェルの正しいパスを入力します。
シェル = explorer.exe
Userinit = C:\windows\system32\userinit.exe
Note
これらのファイルはスパイウェアによって削除される場合もあります。 Windows CD を使用して抽出する必要がある場合があります。
この問題を修正するための手順
ネットワークに接続されたコンピューターにログオンします。
Regedit.exe
を実行します。カーソルを
HKEY_LOCAL_MACHINE
にポイントします。ファイル>リモート レジストリの接続を選択します。
コンピューター名 (感染したコンピューター) を入力します。
移動先または感染したコンピューターのレジストリ内の次の場所に移動します。
HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon
右側のウィンドウで次の 2 つの値を編集します。
Shell
Userinitこれら 2 つの値を次の値に変更します。
シェル = explorer.exe
Userinit = C:\windows\system32\userinit.exeレジストリから終了します。
感染したコンピューターを再起動します。
コンピューターにログオンできる必要があります。
重要
上記の手順で問題が解決しなかった場合は、マシンが侵害されたと見なす必要があります。
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