次の方法で共有


Visual Studio Icon Visual Studio 2017 for Mac 製品ファミリのシステム要件



開発者コミュニティ | システム要件 | 互換性 | 再頒布可能コード | Xamarin | ブログ | サービス


Visual Studio 2017 for Mac ファミリ製品の最小システム要件は、次のとおりです。 Visual Studio 2017 for Mac をインストールする場合は、Visual Studio 2017 のダウンロードに関するページを参照してください。 このリリースでの新しい点については、Visual Studio for Mac 2017 リリース ノートをご覧ください。 また、「Visual Studio 2017 for Mac の対象プラットフォームと互換性」を参照してください。

Visual Studio 2017 for Mac

次の製品は、下記の最小システム要件をサポートします。

  • Visual Studio Enterprise 2017 for Mac。
  • Visual Studio Professional 2017 for Mac。
  • Visual Studio Community 2017 for Mac。

サポート対象のオペレーティング システム

Visual Studio 2017 for Mac は、次のオペレーティング システムにインストールして実行します。

  • macOS Sierra 10.12: Community、Professional、Enterprise。
  • Mac OS X El Capitan 10.11: Community、Professional、Enterprise*。

Xamarin.iOS および Xamarin.Mac プロジェクトでは、Xcode の要件の結果として、より新しい macOS のバージョンを必要とする場合があります。 詳細については、[Xamarin リリースノート](/xamarin/ios/release-notes/) をご覧ください。

ハードウェア

  • 1.8 GHz 以上のプロセッサ。 デュアル コア以上を推奨。
  • 4 GB の RAM (8 GB の RAM を推奨) (仮想マシン上で実行される場合は最小 4 GB)。
  • ハード ディスク容量: 約 1 GB。

サポートされている言語

Visual Studio for Mac は次の言語で利用できます。

  • English
  • 簡体中国語
  • 繁体中国語
  • チェコ語
  • フランス語
  • ドイツ語
  • イタリア語
  • 日本語
  • 韓国語
  • ポーランド語
  • ポルトガル語 (ブラジル)
  • ロシア語
  • スペイン語
  • トルコ語

追加の要件

  • .NET Core プロジェクトおよび機能を使うには、.NET Core SDK 1.1 が必要です。 これは、別途ダウンロードしてインストールすることができ、Mac OS X El Capitan 10.11 以降が必要です。
  • Xamarin.Android には、64 ビット版 Java Development Kit (JDK) が必要です。
  • Xamarin.iOS には、Apple の Xcode IDE と iOS SDK が必要です。
  • 上記の要件を満たす場合、Xamarin.Forms は Android と iOS の両方のプラットフォームを対象にできます。
ページのトップへ