USBオーディオデバイスが再生されない

この記事では、Windows 10 バージョン 1703 で "オーディオ サービスが応答していません" というエラーと USB オーディオ デバイスが機能しない方法について説明します。

現象

以下のシナリオについて考えてみます。

  1. オーディオ アダプターや USB デジタル アナログ コンバーター (DAC) などのユニバーサル シリアル バス (USB) オーディオ デバイスを Windows コンピューターに初めて接続します。
  2. オペレーティング システムはデバイスを検出し、標準の USB オーディオ 2.0 ドライバー (usbaudio2.sys) を読み込みます。
  3. その後、Windows は Windows 更新 からデバイス固有のドライバーをダウンロードします。
  4. ダウンロードしたデバイスドライバがusbaudio2.sysドライバに置き換わります。

このシナリオでは、デバイスは使用できず、コンピューターに音声が聞こえません。 タスクバーのスピーカーアイコンにはXマークが付いています。 アイコンを選択すると、次のメッセージが表示されます:

オーディオサービスが応答しません。 オーディオが正しく動作するには、Windows Audio サービスと Windows Audio End Pointサービスの両方が実行されている必要があります。

原因

この "オーディオが再生されない" 問題は、既定の USB オーディオ 2.0 ドライバー (usbaudio2.sys) が操作に WaveRT ポートを使用するのに対し、デバイス固有のドライバーは使用しないために発生します。 ただし、どちらのドライバーも、デバイス インターフェイスが登録されるときに "波" 参照文字列を使用します。

デバイス固有のドライバーが既定のドライバーを置き換える場合、参照文字列が重複するため、usbaudio2.sys によって作成されたデバイス インターフェイスが引き続き使用されます。 そのため、オペレーティング システムは、新しいドライバーが WaveRT ポートもサポートしていることを前提としています。 新しいドライバーは WaveRT ポートをサポートしていないため、システムはドライバーにアクセスできません。

解決方法

この問題を解決するには、次のいずれかの方法を使用します。

方法 1

次の手順に従って、デバイスをアンインストールします:

  1. デバイス マネージャーを開きます。
  2. デバイスの名前をダブルクリックします。
  3. ドライバータブを選択します。
  4. デバイスのアンインストールを選択します。

Note

このデバイスのドライバー ソフトウェアを削除する チェック ボックスはオンにしないでください。

方法 2

デバイスを別のUSBポートに接続します。 デバイスが別のUSBポートに接続されている場合、問題は発生しない場合があります。

方法 3

デバイスがまだ接続されていない場合は、デバイスのインストーラーを使用して、最初にデバイス固有のドライバーをインストールします。 次に、デバイスを接続します。 Windows では、既定の USB オーディオ 2.0 ドライバーではなく、デバイス固有のドライバーが選択されるようになりました。 この方法は、デバイスの接続後にデバイス固有のドライバーが既定のドライバーを置き換える場合にのみ問題が発生するため、機能します。

関連項目