バグ チェック 0x77: KERNEL_STACK_INPAGE_ERROR

The KERNEL_STACK_INPAGE_ERROR バグ チェックの値は、0x00000077 です。 このバグ チェックは、ページング ファイルからカーネル データの要求されたページをメモリに読み込むことができなかったことを示しています。

重要

この記事は、プログラマー向けです。 コンピューターを使用中に、ブルー スクリーン エラーが表示された場合は、「ブルー スクリーン エラーのトラブルシューティング」を参照してください。

KERNEL_STACK_INPAGE_ERROR パラメーター

メッセージにリストされている 4 つのパラメーターには、2 つの意味があります。

最初のパラメーターが 0、1、または 2 の場合、パラメーターには次の意味があります。

パラメーター 説明

1

0: カーネル データのページがページ キャッシュから取得されました。

1: ページがディスクから取得されました。

2: ページがディスクから取得され、ストレージ スタックから SUCCESS が返されましたが 、Status.Information はPAGE_SIZEと等しくありません。

2

シグネチャを配置する必要があるスタックに表示される値。

3

0

4

カーネル スタック上の署名のアドレス

最初のパラメーターが 0、1、または 2 以外の値の場合、パラメーターには次の意味があります。

パラメーター 説明

1

状態コード

2

I/O 状態コード

3

ページ ファイル番号

4

ページ ファイルへのオフセット

原因

最初のパラメーターが 0 または 1 の場合、カーネル スタック内のスタックシグネチャが見つかりませんでした。 このエラーは、RAM エラーなど、ハードウェアの欠陥が原因である可能性があります。

最初のパラメーターが 2 の場合、ドライバー スタックは、ページの読み取りの一貫性のない状態を返しました。 たとえば、ページ全体を読み取らなかった場合でも、ドライバー スタックは成功の状態を返しました。

最初のパラメーターが 0、1、または 2 以外の値である場合、最初のパラメーターの値は、ドライバー スタックがカーネル データのページを取得しようとした後に返される NTSTATUS エラー コードです。 このエラーの正確な原因は、I/O 状態コード (2 番目のパラメーター) から確認できます。 いくつかの一般的な状態コードを次に示します。

  • 0xC000009A または STATUS_INSUFFICIENT_RESOURCES は、非ページ プール リソースが無いことを示しています。 この状況コードは、ストレージ スタックのドライバ エラーを示しています。 (ストレージ スタックは、ソフトウェア リソースの可用性に関係なく、常にこのデータを取得できる必要があります)。

  • 0xC000009C または STATUS_DEVICE_DATA_ERROR は、ハード ディスクの不良ブロック (セクター) を示します。

  • 0xC000009D または STATUS_DEVICE_NOT_CONNECTED は、ケーブル接続の不良または緩み、終端、またはコントローラーにハード ディスク ドライブが表示されなかったことを示します。

  • 0xC000016A または STATUS_DISK_OPERATION_FAILED は、ハード ディスク上の不良ブロック (セクター) を示します。

  • 0xC0000185 (STATUS_IO_DEVICE_ERROR) は、SCSI デバイスでの不適切な終了またはケーブル接続の欠陥、または 2 つのデバイスが同じ IRQ を使用しようとしていることを示します。

これらの状態コードは、特定の原因を持つ最も一般的なコードです。 返される可能性のあるその他の状態コードの詳細については、Microsoft Windows Driver Kit (WDK) の Ntstatus.h ファイルを参照してください。

ウイルス感染は、このバグ チェックを引き起こす可能性もあります。

解決方法

不良ブロック問題の解決 : エラー後にコンピューターを再起動できれば、Autochkが自動的に実行され、不良セクターをマッピングしてそれ以上使用されないようにします。

Autochk がハード ディスクでエラーをスキャンしない場合は、ディスク スキャナーを手動で起動できます。 システム パーティションで Chkdsk /f /r を実行します。 ディスク スキャンを開始する前に、コンピューターを再起動する必要があります。 エラーが原因でシステムを起動できない場合は、回復コンソールを使用して Chkdsk /r を実行します。

警告: システム パーティションがファイル割り当てテーブル (FAT) ファイル システムでフォーマットされている場合、Scandisk または別の Microsoft MS-DOS ベースのハード ディスク ツールを使用して MS-DOS からハード ディスク ドライブの整合性を確認すると、Windows で使用される長いファイル名が破損する可能性があります。 Windows オペレーティング システムのバージョンと一致する Chkdsk のバージョンを常に使用します。

ハードウェアの問題の解決: I/O 状態が0xC0000185で、ページング・ファイルが SCSI ディスク上にある場合は、ディスク・ケーブル接続と SCSI 終了をチェックして問題を検出してください。

エラーが発生した RAM の問題を解決する: システム製造元が提供するハードウェア診断 (特にメモリ スキャナー) を実行します。 これらの手順の詳細については、コンピューターのオーナーズ マニュアルを参照してください。

コンピューター内のすべてのアダプター カードが正しく装着されていることを確認します。 アダプター カードの接触不良がないことを確認するには、家電量販店にある、インク消しゴムか電気接点処置を使用します。

イベント ビューアーのシステム ログで、エラーの原因になっているデバイスの特定に役立つ可能性がある追加のエラー メッセージを調べます。 BIOS のメモリ キャッシュを無効にして、このエラーの解決を試みることもできます。

最新の Windows サービス パックがインストールされていることを確認します。

上記の手順でエラーを解決できない場合は、システムのマザーボードを診断テスト用の修復機能に取り込みます。 亀裂、傷付いたトレース、またはマザーボード上の欠陥のあるコンポーネントは、このエラーを引き起こす可能性があります。

ウイルス感染を解決する: ハードディスクのマスター ブート レコードを調べる最新の商用ウイルススキャン ソフトウェアを使用して、コンピュータにウイルスがあるかどうかを確認します。 すべての Windows ファイル システムはウイルスに感染している可能性があります。

関連項目

バグ チェック 0x7A (KERNEL_DATA_INPAGE_ERROR)