バグ チェック 0x8E: KERNEL_MODE_EXCEPTION_NOT_HANDLED

KERNEL_MODE_EXCEPTION_NOT_HANDLED バグ チェックの値は、0x0000008E です。 このバグ チェックは、カーネル モード アプリケーションがエラー ハンドラーがキャッチしなかった例外を生成したことを示します。

重要

この記事は、プログラマー向けです。 コンピューターを使用中に、ブルー スクリーン エラーが表示された場合は、「ブルー スクリーン エラーのトラブルシューティング」を参照してください。

KERNEL_MODE_EXCEPTION_NOT_HANDLED パラメーター

パラメーター 説明

1

処理されなかった例外コード。

2

例外が発生したアドレス

3

トラップ フレーム

4

予約されています。

原因

KERNEL_MODE_EXCEPTION_NOT_HANDLED バグ チェックは、非常に一般的なバグ チェックです。 これを解釈するには、生成された例外を特定する必要があります。

一般的な例外コードには、次のようなものがあります。

  • 0x80000002: STATUS_DATATYPE_MISALIGNMENT は、調整されていないデータ参照が検出されたことを示します。

  • 0x80000003: STATUS_BREAKPOINT は、カーネル デバッガーがシステムにアタッチされていないときに、ブレークポイントまたは ASSERT 発生したことを示します。

  • 0xC0000005: STATUS_ACCESS_VIOLATION は、メモリ アクセス違反が発生したことを示します。

例外コードの完全な一覧については、Microsoft Windows Driver Kit (WDK) の inc ディレクトリにある Ntstatus.h ファイルを参照してください。

解決方法

!analyze デバッグ拡張機能は、バグ チェックに関する情報を表示し、根本原因の特定に役立ちます。 この問題をデバッグする機能がない場合は、いくつかの基本的なトラブルシューティング手法を使用する必要があります。

  • 十分なディスク容量があることを確認してください。

  • バグ チェック メッセージでドライバーがわかる場合は、ドライバーを無効にするか、製造元にドライバーの更新プログラムを確認します。

  • ビデオ アダプターを変更してみてください。

  • BIOS のアップデートについては、ハードウェア ベンダーに確認してください。

  • キャッシュやシャドウなどの BIOS メモリ オプションを無効にします。

この問題をデバッグする予定の場合は、スタック トレースを取得することが困難な場合があります。 パラメータ 2 (例外アドレス) は、この問題の原因となったドライバーまたは関数を識別する必要があります。

例外コード 0x80000003 が発生した場合、ハードコーディングされたブレークポイントまたはアサーションがヒットしましたが、/NODEBUG スイッチを使用してコンピューターが起動されました。 この問題はあまり発生しません。 繰り返し発生する場合は、カーネル デバッガーが接続されていること、およびコンピューターが /DEBUG スイッチで起動されていることを確認します。

例外コード 0x80000002 が発生した場合、トラップ フレームは追加情報を提供します。

例外の具体的な原因がわからない場合は、次の点を考慮してください。

  • ハードウェアの非互換性。 インストールされた新しいハードウェアが、インストールされている Windows のバージョンと互換性があることを確認します。

  • デバイス ドライバーまたはシステム サービスの障害。 このエラーは、デバイス ドライバーまたはシステム サービスの障害が原因である可能性があります。 BIOS の非互換性、メモリの競合、IRQ の競合などのハードウェアの問題でも、このエラーが発生する可能性があります。

バグ チェック メッセージにドライバーが名前ごとに一覧されている場合は、そのドライバーを無効にするか、削除します。 また、最近追加されたドライバーまたはサービスを無効化または削除します。 スタートアップシーケンス中にエラーが発生し、システム パーティションが NTFS ファイル システムでフォーマットされている場合は、セーフ モードを使用して、障害のあるドライバーの名前を変更または削除できる可能性があります。 ドライバーがセーフ モードでシステム起動プロセスの一部として使用されている場合は、ファイルにアクセスするために回復コンソールを使用してコンピューターを起動する必要があります。

問題が Win32k.sys に関連付けられている場合、エラーの原因はサードパーティのリモート コントロール プログラムである可能性があります。 このようなソフトウェアがインストールされている場合は、復元コンソールを使用してシステムを起動し、問題のあるシステム サービス ファイルを削除することで、サービスを削除できます。

イベント ビューアーのシステム ログで、バグ チェック 0x8E の原因になっているデバイスまたはドライバーの特定に役立つ可能性がある追加のエラー メッセージを調べます。 BIOS のメモリ キャッシュを無効にして、エラーの解決を試みることもできます。 また、システムの製造元が提供したメモリ スキャナーに対して特に、ハードウェア診断を実行する必要があります。 これらの手順の詳細については、コンピューターのオーナーズ マニュアルを参照してください。

このメッセージを生成するエラーは、Windows セットアップ中の最初の再起動後、またはセットアップの完了後に発生する可能性があります。 エラーの原因として考えられるのは、インストールとシステム BIOS の非互換性のためのディスク領域の不足です。 ディスク領域の不足に関連する Windows のインストール中に問題が発生した場合は、ターゲット ハード ディスク ドライブ上のファイルの数を減らします。 必要のない一時ファイル、インターネット キャッシュ ファイル、アプリケーション バックアップ ファイル、ディスク スキャンの保存されたファイル フラグメントを含む .chk ファイルを確認して削除します。 インストール用の空き領域が増えた別のハード ディスク ドライブを使用することもできます。