ツール バー ボタン - WinDbg (クラシック)

ブレークポイント ボタンを除き、ツール バーの各ボタンはメニュー コマンドと同じです。 ツール バーのボタンには、次の効果があります。

ボタン 説明
ツール バーの [オープン ソース ファイル] ボタンのスクリーンショット。 ソース ファイルを読み取り専用ファイルとして開きます。 ファイル > オープン ソース ファイルと同じです。
ツール バーの [切り取り] ボタンのスクリーンショット。 選択したテキストを作業中のウィンドウから削除し、クリップボードに配置します。 切り取り > 編集と同じです。
ツール バーの [コピー] ボタンのスクリーンショット。 選択したテキストを作業中のウィンドウからクリップボードにコピーします。 > コピーを編集。
ツール バーの [貼り付け] ボタンのスクリーンショット。 カーソルがある場所にテキストをクリップボードに貼り付けます。 編集は>貼り付けと同じです。
ツール バーの [移動] ボタンのスクリーンショット。 実行を開始または再開します。 ブレークポイントに達するか、例外またはイベントが発生するか、プロセスが終了するか、デバッガーがターゲットに介入するまで、実行が続行されます。 デバッグ > Go に相当します。
ツール バーの [再起動] ボタンのスクリーンショット。 プロセスの開始時に実行を再開します。 デバッグ > 再起動と同じです。
ツール バーの [デバッグの停止] ボタンのスクリーンショット。 実行を停止し、ターゲット プロセスを永続的に終了します。 デバッグ > デバッグの停止と同じです。
ツール バーの [中断] ボタンのスクリーンショット。 ユーザー モードでは、このボタンはプロセスとそのスレッドを停止します。 カーネル モードでは、このボタンはターゲット コンピューターに割り込むために使用されます。 コントロールがデバッガーに返されます。 このボタンは、長いデバッガー コマンド ウィンドウの表示を切断する場合にも役立ちます。 Debug > Break と同じです。
ツール バーの [ステップ イン] ボタンのスクリーンショット。 1 つの命令を実行します。 命令が関数呼び出しの場合、デバッガーは関数にステップインします。 デバッグ>「ステップイン」と同じです。
ツール バーの [ステップ オーバー] ボタンのスクリーンショット。 1 つの命令を実行します。 命令が関数呼び出しの場合、デバッガーは 1 つのステップで関数全体を実行します。 デバッグ > ステップ オーバーと同じです。
ツール バーの [ステップ アウト] ボタンのスクリーンショット。 現在の関数の残りの部分を実行し、関数の戻り値が完了すると中断します。 デバッグ > ステップ アウトに相当します。
ツール バーの [カーソルまで実行] ボタンのスクリーンショット。 現在の命令から、アクティブな逆アセンブル ウィンドウまたはソース ウィンドウでマークされた命令まで、すべての命令を実行します。 > カーソルまで実行は、デバッグと同じです。
ツール バーの [ブレークポイント] ボタンのスクリーンショット。 アクティブ ウィンドウが [ソース] ウィンドウまたは [逆アセンブル] ウィンドウの場合: 現在の行にブレークポイントを挿入します。 (現在の行にブレークポイントが既に設定されている場合、このボタンはブレークポイントを削除します)。それ以外の場合: [ブレークポイントの編集] > [ブレークポイント] ダイアログ ボックスを開きます。
ツール バーの [コマンド] ボタンのスクリーンショット。 デバッガー コマンド ウィンドウを開くかアクティブにします。 View > コマンドと同じです。
ツール バーの [ウォッチ] ボタンのスクリーンショット。 [ウォッチ] ウィンドウを開くかアクティブにします。 > ウォッチを表示する。
ツール バーの [ローカル] ボタンのスクリーンショット。 [ローカル] ウィンドウを開くかアクティブにします。 >ローカルの表示と同じです。
ツール バーの [Registers]\(登録\) ボタンのスクリーンショット。 [レジスタ] ウィンドウを開くかアクティブにします。 ビュー > レジスタと同じです。
ツール バーの [メモリ] ボタンのスクリーンショット。 新しい [メモリ] ウィンドウを開きます。 メモリ > 表示と同じです。
ツール バーの [呼び出し履歴] ボタンのスクリーンショット。 [通話] ウィンドウを開くかアクティブにします。 > 呼び出し履歴の表示に相当します。
ツール バーの [逆アセンブル] ボタンのスクリーンショット。 逆アセンブル ウィンドウを開くかアクティブにします。 ビュー > 逆アセンブルと同じです。
ツール バーの [スクラッチ パッド] ボタンのスクリーンショット。 スクラッチ パッドを開くかアクティブにします。 > スクラッチパッドの表示に相当します。
ツール バーの [ソース モード] ボタンのスクリーンショット。 ソース モードとアセンブリ モードのデバッグを切り替えます。 デバッグ > ソース モードを選択またはクリアすることと同じです。
ツール バーの [フォント] ボタンのスクリーンショット。 デバッグ情報ウィンドウで使用されるフォントを変更できます。 ビュー > フォントに相当します。
ツール バーの [オプション] ボタンのスクリーンショット。 [オプション] ダイアログ ボックスを表示します。 ビュー > オプションと同じです。

こちらも参照ください

デバッガー コマンド ウィンドウ