2. Photon Unity ネットワークの設定

このチュートリアルでは、Photon Unity Networking (PUN) を使用して共有エクスペリエンスを作成する準備をします。 PUN アプリを作成し、PUN アセットをUnity プロジェクトにインポートし、Unity プロジェクトを PUN アプリに接続する方法について説明します。

目標

  • PUN アプリを作成する方法について説明します
  • PUN 資産を検索してインポートする方法について説明します
  • Unity プロジェクトを PUN アプリに接続する方法について説明します

Unity プロジェクトの作成と準備

このセクションでは、新しいUnity プロジェクトを作成し、MRTK 開発の準備をします。

まず、 プロジェクトの初期化と最初のアプリケーションのデプロイに従います。 オブジェクトへの手の操作の追加 と デバイスへのアプリケーションのビルド の手順を除きます。これには、次の手順が含まれます。

  1. Unity プロジェクトを作成し、適切な名前を付けます (MRTK チュートリアルなど)
  2. ビルド プラットフォームの切り替え
  3. TextMeshPro Essential リソースのインポート
  4. Mixed Reality ツールキットのインポートとUnity プロジェクトの構成
  5. シーンの作成と MRTK の構成、シーンに適切な名前 (MultiUserCapabilities など) を指定する

次に、[ 空間認識表示オプションの変更] の指示に従って、次の操作を行います。

  1. MRTK 構成プロファイルを DefaultHoloLens2ConfigurationProfile に変更します。
  2. 空間認識メッシュの表示オプションを [オクルージョン] に変更します。

追加機能の有効化

[Unity] メニューの [編集>Project Settings... を選択して [プレイヤー設定] ウィンドウを開き、[Player>Publishing Settings] セクションを探します。

Unityプレーヤーの設定

[発行設定] で、[機能] セクションまで下にスクロールし、[Unity プロジェクトの構成] ステップで有効にした InternetClient、Microphone、SpatialPerception、GazeInput の各機能が有効になっていることをダブルチェックします。

次に、次の他の機能を有効にします。

  • InternetClientServer 機能
  • PrivateNetworkClientServer 機能

Unity機能の設定

チュートリアル資産のインポート

次のUnityカスタム パッケージを一覧表示された順序でダウンロードしてインポートします。

ヒント

 Unityカスタム パッケージをインポートする方法に関するリマインダーについては、「チュートリアル資産のインポート」の手順を参照してください。

注:

MultiUserCapabilities チュートリアルアセット パッケージをインポートすると、コンソール ウィンドウに型または名前空間が見つからないことを示す CS0246 エラーがいくつか表示されます。 これは想定されており、PUN 資産をインポートするときに、次のセクションで解決されます。

PUN アセットのインポート

[Unity] メニューで、[ウィンドウ>Asset Store] を選択して [アセット ストア] ウィンドウを開き、[PUN 2 - ゲームの終了] から [PUN 2 - FREE] を検索して選択し、[ダウンロード] ボタンをクリックしてアセット パッケージをUnity アカウントにダウンロードします。

ダウンロードが完了したら、[インポート] ボタンをクリックして、[Unity パッケージのインポート] ウィンドウを開きます。

UNITYアセットストアとPUN 2 - 無料

[Unity パッケージのインポート] ウィンドウで、[すべて] ボタンをクリックしてすべての資産が選択されていることを確認し、[インポート] ボタンをクリックしてアセットをインポートします。

PUN 2 インポート ウィンドウを使用したUnity

インポート プロセスUnity完了すると、[Pun Setup]\(PUN セットアップ\) メニューが読み込まれた [Pun Wizard]\(パン ウィザード\) ウィンドウが表示されたら、このウィンドウを無視または閉じることができます。

[PUN セットアップを使用したUnity] ウィンドウ

PUN アプリケーションの作成

このセクションでは、Photon アカウントをまだ作成していない場合は作成し、新しい PUN アプリを作成します。

Photon ダッシュボード に移動し、使用するアカウントが既にある場合はサインインします。それ以外の場合は、[ 作成] リンクをクリックし、指示に従って新しいアカウントを登録します。

Photon ログイン ページ

サインインしたら、[ 新しいアプリの作成 ] ボタンをクリックします。

Photon ダッシュボードのウェルカム ページ

[新しいアプリケーションの作成] ページで、次の値を入力します。

  • [Photon Type]\(フォトンタイプ\) で[PUN]\(PUN\)
  • [名前] に適切な名前を入力します ( MRTK チュートリアルなど)
  • [説明] に、必要に応じて適切な説明を入力します
  • [Url] の場合は、フィールドを空のままにします

次に、[ 作成 ] ボタンをクリックして新しいアプリを作成します。

Photon アプリケーションの作成ページ

Photon が作成プロセスを完了すると、新しい PUN アプリがダッシュボードに表示されます。

Photon アプリケーション ページ

Unity プロジェクトを PUN アプリケーションに接続する

このセクションでは、Unity プロジェクトを前のセクションで作成した PUN アプリに接続します。

Photon ダッシュボードで、[ アプリ ID ] フィールドをクリックしてアプリ ID を表示し、クリップボードにコピーします。

アプリ ID が選択された Photon アプリケーション ページ

[Unity] メニューで、[ウィンドウ>Photon Unity ネットワーク>PUN ウィザード] を選択して [パン ウィザード] ウィンドウを開き、[セットアップ プロジェクト] ボタンをクリックして PUN セットアップ メニューを開き、次のように構成します。

  • [AppId] または [Email] フィールドに、前の手順でコピーした PUN アプリ ID を貼り付けます

次に、[ プロジェクトのセットアップ ] ボタンをクリックしてアプリ ID を適用します。

AppId が入力された [PUN セットアップ] ウィンドウをUnityする

PUN セットアップ プロセスUnity完了すると、[PUN セットアップ] メニューに [完了! ] というメッセージが表示され、[プロジェクト] ウィンドウで PhotonServerSettings アセットが自動的に選択されるため、そのプロパティが [インスペクター] ウィンドウに表示されます。

セットアップ プロジェクトが適用された [PUN セットアップ] ウィンドウをUnityする

おめでとうございます

PUN アプリが正常に作成され、Unity プロジェクトに接続されました。 次の手順では、複数のユーザーが相互に表示できるように、他のユーザーとの接続を許可します。