Power BI Desktop을 사용하면 데이터 세계에 연결하여 강력하고 근본적인 보고서를 만들고, 다른 사용자와 작업을 공유할 수 있습니다. 이러한 사용자는 해당 작업을 기반으로 하여 비즈니스 인텔리전스 작업을 확장할 수 있습니다.
Power BI Desktop 보기
Power BI Desktop에는 세 가지 보기가 있습니다.
- 보고서 보기 – 표시하고자 하는 대로 정렬되고 복수의 페이지를 가진 뛰어난 시각화를 작성하기 위해 생성한 쿼리를 사용하고 타인과 공유할 수 있습니다.
- 테이블 보기 – 측정값을 추가하고, 새 열을 만들고, 관계를 관리할 수 있는 데이터 모델 형식으로 보고서의 데이터를 확인합니다.
- 모델 보기 – 사용자의 데이터 모델에 설정되고 필요에 따라 관리 또는 수정하는 관계의 그래픽 표현을 가져옵니다.
이 보기들은 Power BI Desktop의 왼쪽에 있는 세 개의 아이콘 중 하나를 선택하여 액세스합니다. 다음 그림에서는 아이콘 옆에 노란색 줄로 표시된 보고서 보기가 선택되었습니다.
Power BI Desktop은 Power Query 편집기와 함께 제공됩니다. Power Query 편집기를 사용하여 하나 이상의 데이터 원본에 연결하고, 요구 사항에 맞게 데이터의 모양을 지정하고 변환한 다음, 해당 모델을 Power BI Desktop에 로드합니다.
이 문서는 Power Query 편집기에서 데이터로 작업하는 방법에 대한 개요를 제공하지만 더 자세히 알아볼 내용이 있습니다. 이 문서의 끝에서 지원되는 데이터 형식에 관한 자세한 지침 링크를 찾을 수 있습니다. 또한 데이터에 연결, 데이터 모양 지정, 관계 만들기 및 시작하는 방법에 대한 지침도 찾을 수 있습니다.
그러나 우선은 Power Query 편집기를 숙지해 보겠습니다.
Power Query 편집기
Power BI Desktop은 두 가지 Power Query 편집기 환경을 제공합니다.
- 새로운 파워 쿼리 환경(미리 보기): Power BI Desktop, 웹 모델링 및 기타 Fabric 제품에서 간소화된 탐색, 향상된 접근성 및 일관된 파워 쿼리 환경을 갖춘 새롭게 디자인된 편집기입니다.
- 기존 환경: 원래의 Power Query 편집기 창입니다.
두 환경 모두에서 Power Query 편집기 사용하여 하나 이상의 데이터 원본에 연결하고, 필요에 맞게 데이터를 셰이프 및 변환한 다음, 결과를 Power BI Desktop에 로드합니다. 사용 중인 환경과 일치하는 탭을 선택합니다.
알려진 제한 사항, 해결 방법 및 피드백을 공유할 수 있는 곳은 새로운 파워 쿼리 환경의 알려진 제한 사항 및 해결 방법을 참조하세요.
Note
새 파워 쿼리 환경은 미리 보기로 제공됩니다.
사전 요구 사항
Power BI 새로운 파워 쿼리 환경 미리 보기 기능이 사용하도록 설정된 Desktop입니다.
새 파워 쿼리 환경을 사용하도록 설정하려면 다음을 수행합니다.
- Power BI Desktop을 시작하세요.
- 파일>옵션 및 설정>옵션으로 이동합니다.
- 프레뷰 기능을 선택한 다음, 새로운 파워 쿼리 환경 확인란을 선택합니다.
- 확인을 선택합니다.
동일한 미리 보기 기능을 사용하면 새 데이터 가져오기 환경과 새 Power Query 편집기 모두 사용할 수 있습니다. 레거시 편집기로 돌아가려면 확인란의 선택을 취소합니다. Power BI Desktop을 다시 시작할 필요가 없습니다. 새 데이터 가져오기 환경에 대한 자세한 내용은 Power BI Desktop에서 데이터 가져오기를 참조하세요.
Power Query 편집기 열기
Power Query 편집기 열려면 Power BI Desktop의 홈 탭에서 데이터 변환을 선택합니다.
데이터 연결이 없는 경우, Power Query 편집기는 데이터를 받을 준비가 된 빈 창으로 나타납니다. 쿼리를 로드한 후 편집기는 5개의 고유한 구성 요소를 제공합니다. 다음 표의 숫자는 스크린샷에 있는 번호가 매겨진 호출 표시와 대응합니다.
| # | Component | Description |
|---|---|---|
| 1 | 리본 | 여러 탭을 제공하여 변환을 추가하고, 쿼리 옵션을 선택하고, 다양한 리본 단추에 액세스하여 다양한 작업을 완료하는 리본 탐색 환경입니다. |
| 2 | 쿼리 창 | 사용 가능한 모든 쿼리의 보기입니다. |
| 3 | 현재 보기 | 기본 작업 보기는 기본적으로 쿼리에 대한 데이터의 미리 보기를 표시합니다. 데이터 미리 보기와 함께 다이어그램 보기를 사용하도록 설정할 수도 있습니다. 다이어그램 보기를 유지하면서 스키마 뷰와 데이터 미리 보기 간에 전환할 수 있습니다. |
| 4 | 쿼리 설정 | 쿼리 이름, 쿼리 단계 및 다양한 지표와 같은 관련 정보가 있는 현재 선택된 쿼리의 보기입니다. |
| 5 | 상태 표시줄 | 실행 시간, 총 열 및 행, 처리 상태 등 쿼리에 대한 중요한 정보를 보여 주는 막대입니다. 이 막대에는 현재 보기를 변경하는 단추도 포함되어 있습니다. |
이러한 각 구성 요소는 다음 섹션에서 설명합니다. 파워 쿼리 사용자 인터페이스의 전체 연습은 파워 쿼리 사용하여 데이터 변환을 참조하세요.
리본
리본 메뉴는 Power Query 편집기 수행할 수 있는 대부분의 변환 및 작업을 찾을 수 있는 구성 요소입니다. 명령은 홈, 변환, 열 추가, 보기, 도구 및 도움말 탭에서 그룹화됩니다. 각 탭에는 필요한 변환 및 작업에 쉽게 액세스할 수 있는 특정 단추와 옵션이 제공됩니다.
홈 탭에는 데이터에 연결하고 쿼리 작성 프로세스를 시작하는 데 사용하는 데이터 가져오기 명령을 비롯한 일반적인 쿼리 작업이 포함되어 있습니다. 사용 가능한 데이터 원본에 대한 자세한 내용은 Power BI Desktop의 데이터 원본을 참조하세요. 커넥터 사용에 대한 자세한 내용은 데이터 가져오기 개요를 참조하세요.
변환 탭에서는 열 추가 또는 제거, 데이터 형식 변경, 열 분할과 같은 일반적인 데이터 변환 작업에 액세스할 수 있습니다. 열 추가 탭은 열 추가, 열 데이터 서식 지정 및 사용자 지정 열 추가와 관련된 더 많은 작업을 제공합니다. 보기 탭은 표시되는 창과 보기를 제어하고 고급 편집기 엽니다.
파워 쿼리 인터페이스는 응답성이 뛰어나 화면 해상도에 맞게 조정됩니다. 리본의 압축 버전을 원하는 경우 리본의 오른쪽 아래 모서리에 있는 축소 단추를 선택합니다. 표준 리본 메뉴로 다시 전환하려면 같은 모서리에서 확장 아이콘을 선택합니다.
리본에서 사용할 수 있는 대부분의 작업은 현재 보기에서 열 또는 기타 데이터를 마우스 오른쪽 단추로 클릭하여 사용할 수도 있습니다. 변환 기능은 여러 위치에서 액세스할 수 있는 경우가 많으므로, 선호하는 방식을 사용할 수 있습니다.
데이터를 변환하는 방법에 대한 자세한 내용과 예제는 다음 자습서: Power BI Desktop에서 데이터 셰이핑 및 결합을 참조하세요.
쿼리 창
쿼리 창에는 사용 가능한 모든 쿼리가 표시됩니다. 쿼리를 선택하면 해당 데이터가 현재 보기에 표시됩니다. 여기서 요구 사항에 맞게 데이터를 셰이프하고 변환할 수 있습니다.
쿼리 창의 오른쪽 위 모서리에 있는 아이콘을 선택하여 창을 축소하고 다시 선택하여 창을 확장합니다. 인터페이스 전체에서 유사한 아이콘을 사용하면 다른 보기와 섹션을 축소하거나 확장할 수 있으므로 가장 중요한 보기에 집중할 수 있습니다.
자세한 내용은 쿼리 창을 참조하세요.
현재 보기
현재 보기는 기본 작업 보기입니다. 기본적으로 선택한 쿼리에 대한 데이터 미리 보기가 표시됩니다. 이 영역에서 많은 쿼리 작업을 수행합니다. 열 머리글을 선택하거나 마우스 오른쪽 단추로 클릭하여 해당 열에 사용할 수 있는 변환을 확인합니다. 이러한 항목의 대부분은 리본 탭의 단추와 동일합니다.
변환을 선택하면 쿼리가 해당 단계를 데이터에 적용합니다. 또한 쿼리 자체의 일부로 단계를 저장합니다. 쿼리 설정 창은 이 문서의 뒷부분에 설명된 대로 단계를 순차적으로 기록합니다.
또한 데이터 프로파일링 도구를 사용하여 값 분포 및 열 품질을 포함하여 데이터를 더 잘 이해할 수 있습니다. 편의를 위해 보기 탭에서 이러한 도구를 사용하도록 설정하고 사용하지 않도록 설정합니다. 자세한 내용은 데이터 프로파일링 도구 사용을 참조하세요.
보기 간 전환
창과 구역을 축소하는 것 외에도 표시되는 보기를 전환할 수도 있습니다. 리본의 보기 탭으로 이동하여 인터페이스의 모양을 제어하는 미리 보기 및 레이아웃 그룹을 찾습니다.
상태 표시줄의 오른쪽에는 다이어그램, 데이터 및 스키마 보기에 대한 아이콘도 포함됩니다. 이러한 아이콘을 사용하여 보기 간에 변경하거나 선택한 보기를 사용하거나 사용하지 않도록 설정합니다.
가장 편안하게 작업할 수 있는 보기 및 레이아웃을 찾으려면 다음 옵션을 시도해 보세요.
스키마 보기
스키마 보기는 열 이름 및 데이터 형식과 같이 테이블의 스키마 구성 요소와만 상호 작용하는 빠르고 간단한 방법을 제공합니다. 열 제거, 열 이름 바꾸기, 열 데이터 형식 변경, 열 순서 변경 또는 열 복제와 같은 스키마 관련 작업을 수행하려는 경우 스키마 보기를 사용합니다.
스키마 보기가 활성화되면 열에 적용되는 작업이 포함된 스키마 도구 탭이 리본에 표시됩니다.
자세한 내용은 스키마 보기 사용을 참조하세요.
다이어그램 보기
다이어그램 보기를 사용하면 쿼리의 구조와 프로젝트의 다른 쿼리와 상호 작용하는 방법을 시각화할 수 있습니다. 쿼리의 각 단계에는 사용된 변환을 인식하는 데 도움이 되는 고유한 아이콘이 있으며, 선은 단계를 연결하여 종속성을 보여 줍니다.
데이터 미리 보기와 다이어그램 보기를 모두 사용하도록 설정하면 데이터 미리 보기 위에 다이어그램 보기가 표시됩니다. 다이어그램 보기를 사용하도록 설정한 상태에서 더하기 기호를 선택하여 쿼리에 추가할 새 변환을 검색합니다.
자세한 내용은 다이어그램 보기를 참조하세요.
쿼리 설정 창
쿼리 설정 창에는 현재 선택한 쿼리에 대한 정보(예: 쿼리 이름, 해당 단계 및 다양한 표시기)가 표시됩니다. 쿼리에 적용된 모든 변환은 적용된 단계 섹션의 단계로 저장됩니다.
쿼리가 단계별로 변환되는 방법을 확인해야 하는 경우 특정 지점에서 쿼리가 어떻게 확인되는지 미리 보는 단계를 선택합니다.
기본 데이터는 변경되지 ‘않는다는 것’을 알고 있어야 합니다. 대신 Power Query 편집기는 데이터 보기를 조정하고 모양을 구성합니다.
필요에 따라 단계 이름을 바꾸거나, 단계를 삭제하거나, 단계를 다시 정렬할 수 있습니다. 이렇게 하려면 적용된 단계 섹션의 단계를 마우스 오른쪽 단추로 클릭하고 표시되는 메뉴에서 선택합니다. 속성을 선택하여 단계의 이름을 변경하거나 설명을 추가합니다. 모든 쿼리 단계는 표시되는 순서대로 수행됩니다.
자세한 내용은 적용된 단계 목록 사용을 참조하세요.
상태 막대
상태 표시줄은 편집기 아래쪽에 표시되며 실행 시간, 총 열 및 행, 처리 상태 등 쿼리에 대한 중요한 정보를 표시합니다. 상태 표시줄의 오른쪽에는 현재 보기를 변경하는 데 사용할 수 있는 아이콘도 포함되어 있습니다.
수식 입력 표시줄
수식 입력줄에는 선택한 단계의 파워 쿼리 M 수식 언어 식이 표시됩니다. 수식 입력줄에서 직접 식을 편집하여 단일 단계를 조정하거나 고급 편집기 사용하여 전체 쿼리 스크립트를 사용할 수 있습니다.
도움받기
Power Query 편집기 도움말 탭은 Power BI 정보에 대한 링크를 제공합니다. 파일>도움말을 선택하면 같은 도움말 옵션에 액세스할 수 있습니다.
고급 편집기
고급 편집기를 사용하면 각 단계에서 Power Query 편집기가 만드는 코드를 볼 수 있습니다. 또한 파워 쿼리 M 수식 언어로 고유한 코드를 만들 수 있습니다. 고급 편집기를 시작하려면 리본 메뉴에서 보기를 선택한 다음 고급 편집기를 선택합니다. 선택한 쿼리에 대해 생성된 코드를 보여 주는 창이 나타납니다.
고급 편집기 창에서 코드를 직접 편집할 수 있습니다. 창을 닫으려면 완료 또는 취소 단추를 선택합니다.
고급 편집기 새 환경과 레거시 환경에서 모두 사용할 수 있습니다. 위의 스크린샷은 레거시 환경을 보여줍니다. 일부 고급 편집기 컨트롤 및 표시 옵션은 새 환경에서 다릅니다. 자세한 내용은 알려진 새로운 파워 쿼리 환경의 제한 사항 및 해결 방법을 참조하세요.
작업 내용 저장
원하는 위치에 쿼리가 있는 경우 Power Query 편집기의 파일 메뉴에서 닫기 및 적용을 선택합니다. 이 작업은 변경 내용을 적용하고 편집기를 닫습니다.
Power BI Desktop은 진행 상태를 대화 상자로 표시합니다.
준비가 되면 Power BI Desktop이 작업을 .pbix 파일 양식으로 저장할 수 있습니다.
작업을 저장하려면 다음 그림과 같이 파일>저장(또는 파일>다른 이름으로 저장)을 선택합니다.
관련 콘텐츠
Power BI Desktop에서 모든 종류의 작업을 수행할 수 있습니다. 해당 기능에 대한 자세한 내용은 다음 리소스를 확인하세요.