Het kenmerk MailNickName of Alias in Exchange Online komt niet overeen met wat is ingesteld in Exchange on-premises

Symptomen

Het Alias kenmerk of Mailnickname in Microsoft Exchange Online komt niet overeen met wat is ingesteld in de on-premises Exchange-omgeving voor een gesynchroniseerd gebruikersaccount.

Oorzaak

Dit probleem treedt op als er wijzigingen worden aangebracht in de USER Principal Name (UPN) voor de gebruiker en de Mailnickname kenmerkwaarde wordt gewijzigd in het voorvoegsel van de UPN.

Oplossing

U kunt dit probleem oplossen door het Alias kenmerk of Mailnickname bij te werken. Gebruik een van de volgende manieren om dit te doen.

Methode 1: Exchange Management Shell gebruiken

  1. Wijzig de bestaande Alias kenmerkwaarde zodat de wijziging wordt gevonden door Microsoft Entra Connect. Hiermee moet de wijziging naar Microsoft 365 worden gesynchroniseerd. Gebruik hiervoor de Set-Mailbox cmdlet of Set-RemoteMailbox , op basis van het type ontvanger in Exchange on-premises.

    • Set-RemoteMailbox

      $alias=Get-remotemailbox <user@domain.com>
      Set-RemoteMailbox <user@domain.com> -alias "$($alias.alias)1"
      
    • Set-Mailbox

      $alias=Get-mailbox <user@domain.com>
      Set-Mailbox <user@domain.com> -alias "$($alias.alias)1"**
      
  2. Start een Delta-synchronisatie vanuit Microsoft Entra Connect of wacht tot Microsoft Entra Connect de delta uitvoert. In het ideale geval worden hiermee de wijzigingen die zijn aangebracht in stap 1 naar Microsoft 365 gesynchroniseerd.

  3. Wijzig de waarde van het kenmerk in de Alias oorspronkelijke waarde. Voer hiervoor een van de volgende cmdlets uit:

    Set-RemoteMailbox <user@domain.com> -alias "$($alias.alias)"
    
    Set-Mailbox <user@domain> -alias "$($alias.alias)"
    
  4. Start een Delta-synchronisatie vanuit Microsoft Entra Connect of wacht tot Microsoft Entra Connect de delta> uitvoert. In het ideale geval worden de wijzigingen in Microsoft 365 gesynchroniseerd.

Methode 2: Active Directory PowerShell-module gebruiken

  1. Wijzig de Mailnickname kenmerkwaarde zodat de wijziging wordt gedetecteerd door Microsoft Entra Connect. Hiermee moet de wijziging naar Microsoft 365 worden gesynchroniseerd. Voer hiervoor de volgende set cmdlets uit:

    $mailnickname=Get-ADUser -Properties * -Filter {name -like '<username>*'}
    Get-ADUser -Properties * -Filter {name -like '<username>*'} | set-aduser -replace @{mailnickname="$($mailnickname.mailnickname)1"
    
  2. Start een Delta-synchronisatie vanuit Microsoft Entra Connect of wacht tot Microsoft Entra Connect de delta uitvoert. In het ideale geval worden hiermee de wijzigingen die zijn aangebracht in stap 1 naar Microsoft 365 gesynchroniseerd.

  3. Wijzig de waarde van het kenmerk in de Mailnickname oorspronkelijke waarde. Voer hiervoor de volgende cmdlet uit:

    Get-ADUser -Properties * -Filter {name -like '<username>*'} | set-aduser -replace @{mailnickname="$($mailnickname.mailnickname)"
    
  4. Start een Delta-synchronisatie vanuit Microsoft Entra Connect of wacht tot Microsoft Entra Connect de delta uitvoert. In het ideale geval worden hiermee de wijzigingen die zijn aangebracht in stap 1 naar Microsoft 365 gesynchroniseerd.