Delen via


Databaseoverschakeling veroorzaakt een ExAssertException-fout

Symptomen

Wanneer u een databaseoverschakeling start, mislukt de overgang en worden gebeurtenislogboekvermeldingen gegenereerd die lijken op de volgende vermeldingen.

Gebeurtenisvermelding 1

ID: "1001"
Level: "Error"
Source: "MSExchangeIS"
Message: "Microsoft Exchange Server Information Store has encountered an internal logic error. Internal error 
text is (ProcessId perf counter (0) does not match actual process id (34864).) with a call stack of (at 
Microsoft.Exchange.Server.Storage.Common.ErrorHelper.AssertRetail(Boolean assertCondition, String message) at 
Microsoft.Exchange.Server.Storage.Common.Globals.AssertRetail(Boolean assertCondition, String message) at 
Microsoft.Exchange.Server.Storage.StoreCommonServices.PerformanceCounterFactory.CreateDatabaseInstance(StoreDatabase 
database)"

Gebeurtenisvermelding 2

ID: "1002"
Level: "Error"
Source: "MSExchangeIS"
Message: "Unhandled exception (Microsoft.Exchange.Diagnostics.ExAssertException: ASSERT: ProcessId perf counter (0) 
does not match actual process id (34864) at Microsoft.Exchange.Diagnostics.ExAssert.AssertInternal(String formatString, 
Object[] parameters) at Microsoft.Exchange.Server.Storage.Common.ErrorHelper.AssertRetail(Boolean assertCondition, String 
message) at Microsoft.Exchange.Server.Storage.Common.Globals.AssertRetail(Boolean assertCondition, String message) at 
Microsoft.Exchange.Server.Storage.StoreCommonServices.PerformanceCounterFactory.CreateDatabaseInstance(StoreDatabase database)"

Gebeurtenisvermelding 3

ID: "4999"
Level: "Error"
Source: "MSExchange Common"
Message: "Watson report about to be sent for process id: <process ID>, with parameters: E12, c-RTL-AMD64, 
15.01.2375.031, M.E.Store.Worker, M.E.S.Storage.StoreCommonServices, 
M.E.S.S.S.PerformanceCounterFactory.CreateDatabaseInstance, M.E.Diagnostics.ExAssertException, 
6c3-dumptidset, 15.01.2375.031."

Oorzaak

De standaardgrootte van het paginabestand voor de prestatiemeteritems is onvoldoende. De Microsoft Exchange Information Store-service (MSExchangeIS) stelt de standaardgrootte van het paginabestand in.

Oplossing

U kunt het probleem oplossen door de grootte van het paginabestand voor de prestatiemeteritems te vergroten. Voer de onderstaande stappen uit

Belangrijk

Deze sectie, methode of taak bevat stappen voor het bewerken van het register. Als u het register op onjuiste wijze wijzigt, kunnen er echter grote problemen optreden. Het is dan ook belangrijk dat u deze stappen zorgvuldig uitvoert. Maak ter beveiliging een back-up van het register voordat u het wijzigt, zodat u het kunt herstellen als er zich een probleem voordoet. Raadpleeg Een back-up maken van en het herstellen van het register in Windows voor meer informatie over het maken van een back-up en het herstellen van het register.

  1. Voer regedit uit.

  2. Verwijder de volgende registersubsleutel:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS\<server name>-NonReplicated

  3. (Optioneel) Als er een andere Exchange-server beschikbaar is die het probleem niet heeft, kopieert u hetMSExchangeISStorePerfCounters.xml-bestand van die server naar de betreffende server. Het bestand bevindt zich in de map %ExchangeInstallPath%Setup\Perf .

  4. Vergroot de grootte van het paginabestand voor de prestatiemeteritems door de volgende PowerShell-opdrachten uit te voeren om het register bij te werken:

    Add-PSSnapin Microsoft.Exchange.Management.PowerShell.Setup
    New-PerfCounters -DefinitionFileName "$env:exchangeinstallpath\Setup\Perf\MSExchangeISStorePerfCounters.xml" -FileMappingSize 10485760
    
  5. Controleer of de FileMappingSize registerwaarde onder de volgende registersubsleutel overeenkomt met de bijgewerkte grootte van het paginabestand:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeIS Store\Performance

  6. Start de server opnieuw.