Delen via


SCOM rapporteert beschadigde statussets

Symptomen

U ontvangt een melding van Microsoft System Center Operations Manager (SCOM) dat sommige van de beheerde beschikbaarheidsstatussets in uw omgeving beschadigd zijn.

Wanneer u zoekt in het gebeurtenislogboek van Microsoft Windows-toepassingen en -services op de betrokken servers, ziet u dat sommige gebeurtenissen die worden vermeld onder Microsoft>Exchange>ActiveMonitoring>ProbeResult het volgende foutbericht bevatten:

System.ApplicationException: monitoring mailbox <UPN of health mailbox account> not found!
at Microsoft.Exchange.Monitoring.ActiveMonitoring.Common.CommonAccessTokenHelper.
ResolveRootOrgUser(String emailAddress, IRecipientSession& recipientSession)

De traceerlogboeken voor actieve bewaking die zich in de ActiveMonitoringTraceLogs map op de betrokken servers bevinden, bevatten ook een vermelding met de volgende informatie:

Component: "Common"
LogLevel: "Warning"
Method: "CreateMonitoringMailbox"
Source: "DirectoryAccessor.cs:1380"
Message: "Exception is caught trying to disable email address policy in OnPrem for monitoring mailbox: 
<UPN of health mailbox account>, error : Microsoft.Exchange.Data.Directory.ADNoSuchObjectException: 
Active Directory operation failed on <FQDN of domain controller>. The object <DN of health mailbox account> 
does not exist."

Opmerking: de map ActiveMonitoringTraceLogs bevindt zich op %ExchangeInstallPath%\Logging\Monitoring\Monitoring\MSExchangeHMWorker\ActiveMonitoringTraceLogs.

Oorzaak

Wanneer het Exchange Health Manager Worker-proces (MSExchangeHMWorker.exe) een nieuw statuspostvak maakt, wordt geprobeerd de EmailAddressPolicyEnabled parameterwaarde van het postvak in te stellen op False. In omgevingen met meerdere domeincontrollers kunnen vertragingen in Active Directory-replicatie er echter voor zorgen EmailAddressPolicyEnabled dat deze als blijft ingesteld True. In dat scenario treden de volgende problemen op:

  • De mislukte poging van MSExchangeHMWorker.exe om het e-mailadresbeleid uit te schakelen, genereert het foutbericht actieve bewakingstraceringslogboek dat wordt vermeld in de sectie Symptomen.

  • Het e-mailadresbeleid blijft ingeschakeld omdat de mislukte bewerking niet opnieuw wordt geprobeerd in het Exchange Health Manager-werkproces. Afhankelijk van het e-mailadresbeleid van uw organisatie kan aan het SMTP-adres van het postvak een andere waarde worden toegewezen dan de UPN.

  • Sommige actieve bewakingstests genereren fouten in het gebeurtenislogboek toepassingen en services als het SMTP-adres van een postvak niet overeenkomt met de UPN. De test genereert bijvoorbeeld RpsDeepTestPSProxyProbe/CertificateSid.<CN of health mailbox> het foutbericht in het gebeurtenislogboek Toepassingen en services dat wordt weergegeven in de sectie Symptomen. Dergelijke fouten zorgen ervoor dat Operations Manager sommige statussets rapporteert als beschadigd.

Oplossing

Volg deze stappen om het probleem op te lossen:

  1. Voer de volgende opdracht uit om de EmailAddressPolicyEnabled parameterwaarde van elk statuspostvak in te stellen op False:

    Get-Mailbox -Monitoring | Set-Mailbox -EmailAddressPolicyEnabled $False
    
  2. Voer de volgende opdracht uit om ervoor te zorgen dat het primaire SMTP-adres van elk statuspostvak overeenkomt met de UPN:

    Get-Mailbox -Monitoring | Select-Object UserPrincipalName | foreach {Set-Mailbox -Identity $_.UserPrincipalName -PrimarySmtpAddress $_.UserPrincipalName}