Delen via


PRB: Foutbericht: 0x80004005: Algemene fout kan registersleutel niet openen

Symptomen

Wanneer u een pagina opent die verbinding maakt met een Access-database, wordt mogelijk het volgende foutbericht weergegeven in de browser:

Microsoft OLE DB Provider for ODBC Drivers (0x80004005)[Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x614 Thread 0x6c0 DBC 0x21dd07c Jet'.
(FileName), (LineNumber)

Oorzaak

Het account dat wordt gebruikt voor toegang tot de pagina heeft geen toegang tot de HKEY_LOCAL_MACHINE\SOFTWARE\ODBC registersleutel.

Oplossing

Belangrijk

Deze sectie, methode of taak bevat stappen voor het bewerken van het register. Als u het register op onjuiste wijze wijzigt, kunnen er echter grote problemen optreden. Het is dan ook belangrijk dat u deze stappen zorgvuldig uitvoert. Maak een back-up van het register voordat u wijzigingen aanbrengt. Als er een probleem optreedt, kunt u het register altijd nog herstellen. Voor meer informatie over het maken van een back-up en het herstellen van het register, klikt u op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven: 322756 Een back-up van het register maken en herstellen in Windows

  1. Start register Editor (Regedt32.exe).

  2. Selecteer de volgende sleutel in het register:

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC

  3. Klik in het menu Beveiliging op Machtigingen.

  4. Typ de vereiste machtigingen voor het account dat toegang heeft tot de webpagina.

  5. Sluit de Register-editor af.

Status

Dit gedrag is inherent aan het ontwerp van het product.