Delen via


De outlook-client Microsoft Dynamics CRM 2011 kan niet worden geconfigureerd voor het externe IFD-webadres

Dit artikel biedt een oplossing voor het probleem dat gebruikers de Microsoft Dynamics CRM Outlook-client niet kunnen configureren voor het externe webadres en de fout Kan geen verbinding maken met Microsoft Dynamics CRM server omdat uw referenties niet kunnen worden geverifieerd.

Van toepassing op: Microsoft Dynamics CRM 2011
Origineel KB-nummer: 2912175

Symptomen

Wanneer de Microsoft Dynamics CRM 2011-implementatie is geconfigureerd voor Internet Facing Deployment (IFD) met behulp van Active Directory Certificate Services (ADFS), kunnen gebruikers de volgende fout ontvangen wanneer ze proberen de Microsoft Dynamics CRM Outlook-client te configureren voor het externe webadres:

Kan geen verbinding maken met Microsoft Dynamics CRM server omdat uw referenties niet kunnen worden geverifieerd. Controleer uw verbinding of neem contact op met de beheerder voor meer hulp.

Bij het controleren van het configuratielogboek wordt ook de volgende uitzondering vastgelegd:

Fout bij het maken van verbinding met URL: https://crmorg.domain.com/XRMServices/2011/Discovery.svc Uitzondering: System.ServiceModel.EndpointNotFoundException: er is geen eindpunt dat luistert op https://adfs.domain.com/adfs/services/trust/13/username dat het bericht kan accepteren.

Gebruikers kunnen echter nog steeds zonder fouten toegang krijgen tot de externe URL via een webbrowser.

Oorzaak

Het eindpunt /adfs/services/trust/13/username kan zijn ingeschakeld. Wanneer dit eindpunt is ingeschakeld, kan de client de eindpunten usernamemixed en kerberosmixed niet bereiken, waardoor de verificatie mislukt.

Oplossing

Schakel het eindpunt /adfs/services/trust/13/username uit en start de ADFS-service opnieuw. Zie de onderstaande stappen om deze actie uit te voeren:

  1. Open de AD FS-beheerconsole.
  2. Vouw in het linkernavigatiedeelvenster Service uit en selecteer vervolgens Eindpunten.
  3. Zoek in de lijst met eindpunten en klik met de rechtermuisknop op het eindpunt /adfs/services/trust/13/username.
  4. Selecteer Uitschakelen.
  5. Start de AD FS-service opnieuw op.