This.$E_2.contentWindow.document.body is null of geen object een scriptfout wanneer u gegevens invoert in een opzoekveld in Microsoft Dynamics CRM 2011
Dit artikel biedt een oplossing voor een fout die optreedt wanneer u gegevens invoert in een opzoekveld in Microsoft Dynamics CRM 2011.
Van toepassing op: Microsoft Dynamics CRM 2011
Origineel KB-nummer: 2671694
Symptomen
Wanneer u gegevens invoert in een opzoekveld waarvoor de functie voor automatische resolutie en meest recent gebruikte items is ingeschakeld, ontvangt u een scriptfout wanneer u het veld met de tabtoets uitschakelt, zodat automatische resolutie een laatst gebruikte waarde kan kiezen. Wanneer u de scriptfout uitvouwt, ziet u mogelijk een gedetailleerde scriptfout die vergelijkbaar is met het volgende voorbeeld, waarbij wordt verwezen naar MRU-velden of InnerHTML:
<CrmScriptErrorReport>
<ReportVersion>1.0</ReportVersion>
<ScriptErrorDetails>
<Bericht> 'this.$E_2.contentWindow.document.body' is null of niet een object </Message>
<Lijn>6</lijn>
<URL>/_common/global.ashx?ver=1810813519</URL>
<PageURL>/userdefined/edit.aspx?etc=2&pagemode=iframe&sitemappath=Workplace%7cCustomers%7cnav_search</PageURL>
<CrmScriptErrorReport>
<ReportVersion>1.0</ReportVersion>
<ScriptErrorDetails>
<Bericht> kan de waarde van de eigenschap 'innerHTML' niet instellen: object is null of niet gedefinieerd </Bericht>
<Lijn>6</lijn>
<URL>/_common/global.ashx?ver=-1915844570</URL>
<PageURL>/userdefined/edit.aspx?
Oorzaak
Dit gebeurt wanneer u met tabs uit het veld gaat of het formulier opslaat voordat de meest recent gebruikte waarden zijn ingevuld
Oplossing
De huidige tijdelijke oplossingen worden hieronder vermeld:
Optie 1:
In plaats van tekens in het veld in te voeren om de laatst gebruikte waarden te gebruiken, selecteert u de opzoekknop om de record te selecteren in het venster Record opzoeken.
Optie 2:
- Wijs in Microsoft Dynamics CRM instellingen aan, wijs Aanpassing aan en selecteer vervolgens Systeem aanpassen.
- Vouw de betreffende entiteit uit en selecteer formulieren.
- Dubbelklik op het formulier zodat het venster voor het aanpassen van het formulier wordt geopend.
- Zoek het opzoekveld dat het probleem veroorzaakt en dubbelklik om het te openen.
- Selecteer onder Veldgedragautomatische resolutie uitschakelen in het veld en Meest recent gebruikte items voor dit veld uitschakelen.
Optie 3:
Opmerking
Met deze optie worden alle scriptfoutrapporten automatisch naar Microsoft verzonden en wordt voorkomen dat toekomstige Microsoft Dynamics CRM scriptfouten worden weergegeven
Voor afzonderlijke gebruikers:
- Wijs in Microsoft Dynamics CRM naar Bestand, wijs Opties aan en selecteer vervolgens Privacy.
- Selecteer Automatisch een foutenrapport naar Microsoft verzenden zonder mij om toestemming te vragen.
- De scriptfout wordt in deze situatie gestopt.
Voor organisatieniveau:
- Selecteer in Microsoft Dynamics CRM Instellingen, selecteer Beheer en selecteer vervolgens Privacy-instellingen.
- Selecteer het tabblad Foutrapportage .
- Klik om het selectievakje Foutmeldingsvoorkeuren voor webtoepassingen namens gebruikers opgeven te markeren.
- Selecteer Automatisch een foutenrapport naar Microsoft verzenden zonder mij om toestemming te vragen en selecteer vervolgens OK.
Meer informatie
<CallStack>
<Functie>if(IsNull(this.$E_2)||IsNull(this.$E_2.parentNode))return; this.$E_2.contentWindow.document.body.innerHTML=""; this.$E_2.parentNode.removeChild(this.$E_2); this.$E_2=null</Function>
<Functie>(callback)</functie>
<Functie>(callback)</functie>
<Functiefunctie>(){this.$D_0=""; if(! IsNull(Mscrm.LookupMruListUI.$0_0))){Mscrm.LookupMruListUI.$0_0.clear(); Mscrm.LookupMruListUI.$0_0.hide()}if(! IsNull(Mscrm.LookupMruListUI.$7_0))){Mscrm.LookupMruListUI.$7_0.clear(); Mscrm.LookupMruListUI.$7_0.hide() }} </Function>
<Functiefunctie>(){this.$V_0()}</Functie>
<Functie>hideMruInternal()</Functie>
</CallStack>
</ScriptErrorDetails>
<ClientInformation>
<BrowserUserAgent>Mozilla/4.0 (compatibel; MSIE 7.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.04506.648; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; MS-RTC LM 8; AskTbORJ/5.13.1.18107; InfoPath.3)</BrowserUserAgent>
<BrowserLanguage>en-us</BrowserLanguage>
<SystemLanguage>en-us</SystemLanguage>
<UserLanguage>en-us</UserLanguage>
<ScreenResolution>1440x900</ScreenResolution>
<ClientName>Web</ClientName>
<ClientTime>2012-01-26T13:01:56</ClientTime>
</ClientInformation>
<ServerInformation>
<OrgLanguage>1033</OrgLanguage>
<OrgCulture>1033</OrgCulture>
<UserLanguage>1033</UserLanguage>
<UserCulture>1033</UserCulture>
<CRMVersion>5.0.9688.594</CRMVersion>
</ServerInformation>
</CrmScriptErrorReport>