Fout InternetSetCookie mislukt bij het configureren van Microsoft Dynamics CRM voor Microsoft Office Outlook
Dit artikel biedt een oplossing voor een fout die optreedt wanneer u Microsoft Dynamics CRM voor Microsoft Office Outlook configureert.
Van toepassing op: Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2013
Origineel KB-nummer: 3092666
Symptomen
Wanneer u Microsoft Dynamics CRM voor Microsoft Office Outlook probeert te configureren, wordt het volgende foutbericht weergegeven:
"Er is een probleem met de communicatie met de Microsoft Dynamics CRM server. De server is mogelijk niet beschikbaar. Probeer het later opnieuw. Als het probleem zich blijft voordoen, neemt u contact op met uw systeembeheerder.
Wanneer u details selecteert, worden de volgende aanvullende details weergegeven:
InternetSetCookie mislukt met foutcode: 87 bij Microsoft.Crm.CookieManager.SetCookies(Uri webApplicationUri, CookieCollection-cookies, CookieDataFlags cookieFlags, String p3pHeader)
at Microsoft.Crm.CookieManager.SetCookies(URI webApplicationUri, CookieCollection cookies)
op Microsoft.Crm.Outlook.ClientAuth.ClientAuthProviderBase'1.SetWebAppCookies()
Oorzaak
De servernaam in de URL bevat een onderstrepingsteken ("_"). Voorbeeld: https://crm_server
.
Microsoft Dynamics CRM voor Microsoft Office Outlook maakt gebruik van de functie InternetSetCookieExA (wininet.h), die niet werkt als de URL een onderstrepingsteken bevat.
Oplossing
Volg deze stappen om dit probleem op te lossen:
- Maak een DNS-alias voor de server die geen onderstrepingsteken (_) gebruikt. Voorbeeld:
https://crmserver
. - Selecteer in Implementatiebeheer op de Microsoft Dynamics CRM-server Microsoft Dynamics CRM in de linkerbovenhoek en selecteer vervolgens Eigenschappen.
- Selecteer het tabblad Webadres en werk alle URL's bij om de DNS-alias te gebruiken.
- Selecteer OK.
- Probeer Microsoft Dynamics CRM voor Microsoft Office Outlook te configureren met behulp van de nieuwe URL die geen onderstrepingsteken bevat.