Microsoft Dynamics CRM 2011 snel zoeken verschilt per web- en CRM voor Outlook-client
Dit artikel helpt u bij het oplossen van het probleem dat optreedt wanneer u snel zoeken uitvoert in de Microsoft Dynamics CRM 2011-webclient of de Microsoft Dynamics CRM 2011 voor Outlook-client.
Van toepassing op: Microsoft Dynamics CRM 2011, Microsoft CRM-client voor Microsoft Office Outlook
Origineel KB-nummer: 2669792
Symptomen
Wanneer u een zoekopdracht snel zoeken uitvoert in de Microsoft Dynamics CRM 2011-webclient of de Microsoft Dynamics CRM 2011 voor Outlook-client, kunt u verschillende resultaten krijgen.
Open bijvoorbeeld de entiteit Account en maak drie accounts met de volgende accountnamen:
- testvoorbeeld 1
- voorbeeld 1
- Eén voorbeeld
In dit scenario, als een gebruiker in de CRM-webclient snel zoeken naar Account met behulp van de zoektekenreeks sample
, zou de query zoeken met een jokerteken met een toegevoegd achtervoegsel, sample*
vergelijkbaar met zoeken naar en zou resulteren in het retourneren van één record.
Als de gebruiker echter in de Outlook-client heeft gezocht met behulp van snel zoeken naar Accounts met behulp van de zoekreeks sample
, wordt met de query gezocht met een jokerteken met een toegevoegd voorvoegsel en een jokerteken, vergelijkbaar met zoeken naar *sample*
, en resulteert dit in het retourneren van alle drie records.
Oorzaak
In Microsoft Dynamics CRM 4.0 heeft de zoekfunctionaliteit dezelfde resultaten opgeleverd in de Outlook-client en webclient, omdat de zoekopdracht werd verwerkt door de CRM-server. Omdat de Microsoft Dynamics CRM 2011 Outlook-client echter een uitgebreidere integratie met Outlook biedt, kan de client gebruikmaken van de ingebouwde zoekfunctionaliteit van Outlook, waardoor de uitgebreide zoekdekking mogelijk is.
Oplossing
De webclient kan vergelijkbare zoekfunctionaliteit gebruiken met behulp van jokerkaarten voor subtekenreeksen, voorvoegsels en achtervoegsels, samen met andere voorwaarden met behulp van Geavanceerd zoeken.
Als u het zoekgedrag van de Outlook-client wilt emuleren vanuit de webclient, voert u een *
teken in aan het begin van de zoekreeks.
Geavanceerd zoeken kan ook worden gebruikt om gebruik te maken van aanvullende tekenreeksvoorwaarden, zoals Bevat, Gelijk aan, Begint met, Eindigt met, Bevat geen gegevens, die kunnen worden gebruikt voor zoektekenreeksen.
Meer informatie
Dynamics CRM 2011 Updatepakket 12 en hoger wijzigt deze functionaliteit, zodat snel zoeken in de CRM-client voor Outlook en de CRM-webclient zoeken met behulp van vergelijkbare logica. Updatepakket 12 en hoger leidt ertoe dat de CRM-client voor Outlook de gedefinieerde weergave snel zoeken gebruikt bij het uitvoeren van een zoekopdracht voor snel zoeken in plaats van te zoeken in de resultaten van de huidige weergave.