Delen via


Fout MAPI niet beschikbaar in Skype voor Bedrijven 2016-client

Symptomen

In bepaalde situaties is de MAPI-verbinding met Exchange Server mogelijk niet beschikbaar voor Skype voor Bedrijven 2016-clients. Dit probleem treedt op in de volgende scenario's:

  • U hebt een nieuwe installatie van Office 2016 of u maakt een nieuw Outlook 2016 profiel.
  • U voert een upgrade uit van een bestaande Office 2013-installatie naar Office 2016 en maakt vervolgens een nieuw Outlook 2016 Exchange Server-profiel.

Dit probleem kan optreden voor gebruikers van Microsoft 365 Exchange Online of Exchange On-Premises. Wanneer dit probleem zich voordoet, is de MAPI-verbinding niet beschikbaar voor Skype voor Bedrijven 2016-clients. Daarnaast kunt u de volgende symptomen ervaren:

  • De functie Skype voor Bedrijven Configuratie-informatie (houd ctrl ingedrukt en klik met de rechtermuisknop op het pictogram van het Skype voor Bedrijven 2016-systeemvak) geeft de status MAPI niet beschikbaar weer, zoals wordt weergegeven.

    Schermopname van de M A P I-status.

    Als u op het tabblad Gesprekken klikt en vervolgens op Meer weergeven in Outlook klikt, wordt het volgende foutbericht weergegeven:

    Uw Outlook-profiel is niet correct geconfigureerd. Neem contact op met uw ondersteuningsteam met deze informatie.

  • De delegeerfunctionaliteit is mogelijk verbroken. U kunt bijvoorbeeld geen vergadering plannen namens iemand anders. Wanneer u de onlinevergadering probeert te maken, ontvangt u het volgende foutbericht:

    U bent niet gemachtigd om onlinevergaderingen te plannen namens de eigenaar van dit account. Neem contact op met de eigenaar van het account om machtigingen voor gemachtigden in Lync te verkrijgen.

Oorzaak

Dit probleem treedt op omdat Skype voor Bedrijven 2016 de eigenschap PR_PROFILE_USER gebruikt om de beschikbaarheidsinfo op te halen. Microsoft Outlook 2016 schrijft de eigenschap echter niet als onderdeel van de functie Betrouwbare profielen.

Oplossing

U kunt dit probleem oplossen door een van de volgende methoden te gebruiken, afhankelijk van uw Office-installatietype. Zie de sectie 'Meer informatie' om te bepalen of uw Office-installatie msi-gebaseerd is of klik-en-klaar.

Voor MSI-versies van Skype voor Bedrijven 2016

U kunt dit probleem oplossen door de update (KB3115268) van 5 juli 2016 voor Skype voor Bedrijven 2016 te installeren.

Voor klik-en-klaar-versies van Skype voor Bedrijven 2016

Huidig kanaal (CC): opgelost in builds 16.0.7167.2040 en hoger

First Release Deferred Channel (FRDC): Opgelost in builds 16.0.6965.2078 en hoger

Uitgestelde kanaal (DC): opgelost in builds 16.0.6965.2092 en hoger

Zie Microsoft 365-clientupdatekanaalreleases voor meer informatie over C2R Channel-builds.

Tijdelijke oplossing

Belangrijk

Volg de stappen in deze sectie zorgvuldig. Als u het register onjuist bewerkt, kunnen er grote problemen optreden. Maak een back-up van het register voor herstel in geval van problemen voordat u het wijzigt.

Als u dit probleem wilt omzeilen in een Klik-en-Klaar-versie van Skype voor Bedrijven 2016, gebruikt u de tijdelijke oplossing in deze sectie.

Opmerking

Alleen de tijdelijke oplossing zelf wordt ondersteund door het Outlook-team. De voorlopige stappen in de eerste procedure worden niet ondersteund. Deze procedure bevat echter informatie die nodig is om de tijdelijke oplossing te voltooien. Deze stappen bieden ook een methode om te controleren of de tijdelijke oplossing correct is geïmplementeerd en om de wijzigingen indien nodig te herstellen.

Voorlopige stappen (niet ondersteund)

Belangrijk

De volgende procedure wordt niet ondersteund door het Outlook-team en kan andere problemen in Outlook veroorzaken. Gebruik deze procedure op eigen risico. We raden u af om deze procedure te gebruiken. We voegen deze hier echter toe omdat deze eerder is gepubliceerd. Mogelijk moet u deze stappen gebruiken om de eigenschap MAPI PR_PROFILE_USER (of registersleutel) te verwijderen nadat er oplossingen zijn uitgebracht voor alle Klik-en-Klaar-productkanalen.

  1. De Register-editor starten.

    Windows 10

    Typ regedit.exe in het startscherm en tik of klik vervolgens op regedit in de zoekresultaten.

    Windows 8.1 en Windows 8

    Swipe vanaf rechts om de charms te openen, selecteer Zoeken en typ regedit.exe in het zoekvak.

    Windows 7 en Windows Vista

    Klik op Start, typ regedit in het vak Zoekopdracht starten en druk op Enter. Als u wordt gevraagd om een beheerderswachtwoord of om bevestiging, typt u het wachtwoord of klikt u op Toestaan.

  2. Zoek de volgende registersubsleutel:

    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Profiles

  3. Zoek onder deze subsleutel de naam van uw Outlook-profiel en vouw deze uit.

    Opmerking

    Standaard is de profielnaam 'Outlook'. Uw profiel kan echter een andere naam hebben als u het handmatig hebt gemaakt.

  4. Zoek en vouw onder het profiel de sleutel 9375CFF0413111d3B88A00104B2A6676 uit .

  5. Onder de sleutel 9375CFF0413111d3B88A00104B2A6676 ziet u een submap voor elk account in uw profiel. Selecteer de eerste submap (00000001) en onderzoek vervolgens de gegevens van de binaire waarde van de Accountnaam door te dubbelklikken op de waarde. Herhaal dit proces totdat u de waarde accountnaam hebt gevonden die uw SMTP-adres bevat.

  6. Zoek onder de subsleutel \0000000x met uw SMTP-adres de binaire waarde service-UID.

    Opmerking

    Deze waarde vertegenwoordigt een GUID (bijvoorbeeld c3 d1 9a 7b 80 1b c4 4a 96 0a e5 b6 3b f9 7c 7e).

  7. Zoek de submap in uw profiel die overeenkomt met de GUID-waarde die u in stap 6 hebt gevonden (bijvoorbeeld \c3d19a7b801bc44a960ae5b63bf97c7e).

  8. Controleer onder de subsleutel uit stap 7 de binaire waarde 01023d0d .

    Opmerking

    Deze waarde vertegenwoordigt een GUID (bijvoorbeeld 5f cf d5 f1 ba 5c 6f 45 b3 57 cc 5e 0d 16 94 58).

  9. Zoek de submap in uw profiel die overeenkomt met de GUID-waarde uit stap 8 (bijvoorbeeld \5fcfd5f1ba5c6f45b357cc5e0d169458).

  10. Maak op deze locatie een tekenreekswaarde met de naam 001e6603, zoals wordt weergegeven.

    Schermopname van de waarde Tekenreeks.

  11. Zoek de verouderde Exchange-domeinnaam (DN) van de gebruiker.

  12. Houd Ctrl ingedrukt terwijl u met de rechtermuisknop op het pictogram van het Outlook-systeemvak klikt. Selecteer vervolgens Automatische configuratie van e-mail testen.

  13. Schakel in het dialoogvenster dat wordt geopend de selectievakjes GuessSmart gebruiken en Secure Guessmart Authentication uit en klik vervolgens op Testen.

  14. Nadat de test is voltooid, selecteert u het tabblad XML en zoekt u de verouderde DN-waarde, zoals wordt weergegeven.

    Schermopname van het venster Automatische configuratie.

    Kopieer de verouderde DN-gegevens. Hoewel de hele getagde vermelding in deze schermafbeelding is gemarkeerd, is de waarde die u wilt kopiëren alles tussen de <verouderdeDN-tags> . In dit voorbeeld is het /o=Contoso /ou=Exchange-beheergroep (FYDIBOHF23SPDLT)/cn=Recipients/cn=4ef0d05da334258afda34a7ce08a430-TestDir1.

  15. Vul in het register het veld Waardegegevens in met behulp van de verouderde DN-informatie die u zojuist hebt gekopieerd, zoals wordt weergegeven. Klik daarna op OK.

    Schermopname van het venster waarin de MAPI-tekenreekswaarde wordt bewerkt.

Tijdelijke oplossing (ondersteund)

  1. Haal het hulpprogramma MFCMapi op via de volgende website:

    MFCMapi

  2. Start het hulpprogramma op de computer van de betrokken gebruiker.

    Schermopname van de startpagina van het hulpprogramma MFCMapi.

  3. Klik op Profiel en klik vervolgens op Profielen weergeven.

  4. Dubbelklik op het profiel van de betrokken gebruiker. In deze situatie is er alleen het standaardprofiel met de naam 'Outlook'. Als de gebruiker meerdere profielen heeft, selecteert u het profiel dat het primaire gebruikersaccount vertegenwoordigt dat dit probleem ondervindt.

    Schermopname van de profielen in Outlook.

  5. Zoek in de tabel Services die wordt geopend de service met de weergavenaam 'Microsoft Exchange' en dubbelklik vervolgens op die service om deze te openen.

    Schermopname van de Microsoft Exchange-service in de tabel Services.

  6. In de tabel Providers die wordt geopend. zoek en selecteer de provider met het SMTP-adres van de betrokken gebruiker die geen vermeldingen heeft voor 'PR_PROVIDER_DISPLAY'.

    Schermopname van de tabel Providers.

  7. Bekijk in het hulpprogramma MFCMapi het venster Providers om te controleren of de SMTP-adresprovider van de gebruiker is geselecteerd. Zoek vervolgens naar de eigenschap met de naam PR_PROFILE_USER. Als deze eigenschap bestaat, gaat u naar stap 10. Als deze eigenschap niet bestaat, klikt u op Aanvullende eigenschappen in het menu Eigenschap en klikt u vervolgens op de knop Toevoegen .

    Schermopname van de eigenschap Providers.

  8. Typ PR_PROFILE_USER in het dialoogvenster Eigenschapstag .

    Opmerking

    MFCMapi vertaalt de benoemde eigenschapstag in de juiste waarden, zoals weergegeven.

    Schermopname van het venster Eigenschapstageditor.

  9. Klik op OK. Klik vervolgens op OK in de aanvullende venster Eigenschappen.

    Schermopname van de aanvullende eigenschappen.

  10. Voer Test Autodiscovery uit via de procedure Voorlopige stappen om de verouderde Exchange DN (LegDN) van de betrokken gebruiker op te halen. Kopieer deze informatie naar het Klembord.

  11. Klik in het venster Providers met de rechtermuisknop op de eigenschap PR_PROFILE_USER en klik vervolgens op Bewerken.

    Schermopname van de eigenschappeneditor voor de geselecteerde eigenschap.

  12. Plak de LegDN-gegevens van de gebruiker in het tekstvak Ansi en klik vervolgens op OK.

    Schermopname van de pagina Eigenschap Editor voltooid.

    Opmerking

    MFCMapi kan nu twee vermeldingen voor PR_PROFILE_USER weergeven. Dit is een bekend weergaveprobleem dat veilig kan worden genegeerd.

  13. Optioneel: Gebruik de methode die wordt beschreven in Tijdelijke oplossing 1 om de nieuwe registerwaarde te onderzoeken die door MFCMapi is gemaakt en controleer of deze zich in het juiste Outlook-profiel voor de betrokken gebruiker bevindt.

    Schermopname van de Outlook-profielen.

  14. Sluit alle MFCMapi-vensters en register-Editor en test de MAPI-connectiviteit. Meld u ook volledig af bij Skype en controleer of het programma niet wordt uitgevoerd.

  15. Meld u weer aan bij Skype, wacht een paar minuten en controleer vervolgens de Skype-configuratie. De MAPI-status wordt nu weergegeven als OK.

    Schermopname van de M A P I-status in Skype.

    Opmerking

    Het kan enige tijd duren voordat de wijziging van kracht wordt. Mogelijk moet u zich afmelden bij Outlook en Skype voor Bedrijven en vervolgens weer aanmelden om de wijziging te zien.

Meer informatie

Voer de volgende stappen uit om te bepalen of uw Office-installatie is gebaseerd op Klik-en-Klaar of MSI:

  1. Een Office 2016-toepassing starten.
  2. Selecteer In het menu Bestand de optie Account.
  3. Voor Office 2016 Klik-en-Klaar-installaties wordt een item Bijwerkopties weergegeven. Voor msi-installaties wordt het item Bijwerkopties niet weergegeven.
Installatie van Office 2016 Klik-en-Klaar MSI-gebaseerde Office 2016
Schermopname van de Word klik om de installatie uit te voeren. Schermopname van de Word MSI.

Disclaimerinformatie van derden

De producten van derden die in dit artikel worden vermeld, worden vervaardigd door bedrijven die onafhankelijk zijn van Microsoft. Microsoft verleent dan ook geen enkele garantie, impliciet noch anderszins, omtrent de prestaties of de betrouwbaarheid van deze producten.

Meer hulp nodig? Ga naar Microsoft Community.