Problemen met niet-gereed knooppunt oplossen die worden gevolgd door herstelbewerkingen
Dit artikel helpt bij het oplossen van problemen met scenario's waarin een knooppunt in een AKS-cluster (Microsoft Azure Kubernetes Service) de status Niet gereed voor knooppunten weergeeft, maar vervolgens automatisch wordt hersteld naar een goede status.
Symptomen
U ziet dat uw toepassing niet meer reageert terwijl het knooppunt meldt dat het de status Niet gereed heeft. Het knooppunt wordt echter automatisch hersteld en nu is het op zoek naar een hoofdoorzaakanalyse (RCA).
Oorzaak
Mogelijke oorzaken van dit probleem zijn de volgende scenario's:
De API-server is niet beschikbaar en u gebruikt een gereedheidstest voor de implementatie.
Als een pod wordt uitgevoerd, maar niet gereed is, betekent deze situatie dat de gereedheidstest mislukt. Als de gereedheidstest mislukt, is de pod niet gekoppeld aan de service en wordt het verkeer niet doorgestuurd naar het pod-exemplaar.
Hostfouten van virtuele machines (VM's) treden op. Controleer de volgende informatiebronnen om te bepalen of er fouten zijn opgetreden met de VM-host:
- Diagnostische gegevens van AKS
- Azure-status
- Azure-meldingen (voor recente storingen of onderhoudsperioden)
Preventie
Als u wilt voorkomen dat dit probleem zich in de toekomst voordoet, voert u een of meer van de volgende acties uit:
- Zorg ervoor dat uw servicelaag volledig is betaald.
- Verminder het aantal
watch
aanvragen enget
naar de API-server. - Vervang de knooppuntgroep door een gezonde knooppuntgroep.