Problemen met de foutcode 'PublicIPCountLimitReached' oplossen
In dit artikel wordt beschreven hoe u de fout 'PublicIPCountLimitReached' kunt identificeren en oplossen die optreedt wanneer u een AKS-cluster (Azure Kubernetes Service) probeert bij te werken.
Vereisten
Voor dit artikel is Azure CLI versie 2.0.65 of een latere versie vereist. Voer az --version
uit om het versienummer te vinden. Als u Azure CLI moet installeren of upgraden, raadpleegt u De Azure CLI installeren.
Zie de sectie Een AKS-cluster upgraden in Een Azure Kubernetes Service (AKS)-cluster upgraden voor meer informatie over het upgradeproces.
Symptomen
Een upgrade van een AKS-cluster mislukt en u ontvangt het foutbericht 'PublicIPCountLimitReached'.
Oorzaak
De fout treedt op als u het maximum aantal openbare IP-adressen hebt bereikt dat is toegestaan voor uw abonnement.
Oplossing
Als u de limiet of het quotum voor uw abonnement wilt verhogen, gaat u naar de Azure Portal, doet u een ondersteuningsticket voor service- en abonnementslimieten (quota) en stelt u het quotumtype in op Netwerken.
Nadat de quotumwijziging van kracht is geworden, probeert u het cluster te upgraden naar dezelfde versie waarnaar u eerder een upgrade hebt uitgevoerd. Dit proces activeert een afstemming.
az aks upgrade --resource-group <ResourceGroupName> --name <AKSClusterName> --kubernetes-version <KUBERNETES_VERSION>
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Feedback-community van Azure.