Problemen met de foutcode TooManyRequestsReceived of SubscriptionRequestsThrottled oplossen
In dit artikel wordt beschreven hoe u de TooManyRequestsReceived
fout of SubscriptionRequestsThrottled
kunt identificeren en oplossen die optreedt wanneer u een AKS-cluster (Microsoft Azure Kubernetes Service) probeert te verwijderen.
Symptomen
Wanneer u een AKS-cluster probeert te verwijderen, wordt het volgende foutbericht weergegeven:
internalErrorCode: TooManyRequestsReceived
Statuscode: 429
{
bericht: 'Aantal leesaanvragen voor abonnement '.....'' heeft de limiet van '....' overschreden voor tijdsinterval 'XX:XX:XX'. Probeer het opnieuw na '.....' seconden."
}
Oorzaak
Elke bewerking op abonnementsniveau en op tenantniveau is onderhevig aan beperkingslimieten. Deze limieten zijn van toepassing op elk exemplaar van Azure Resource Manager. Wanneer u de limiet hebt bereikt, ontvangt u een HTTP-antwoord dat statuscode 429 aangeeft: 'Te veel aanvragen'.
Oplossing
Het HTTP-antwoord bevat een Retry-After
waarde. Hiermee geeft u het aantal seconden op dat uw toepassing moet wachten (of slaapstand) voordat de volgende aanvraag wordt verzonden. Als u een aanvraag verzendt voordat de waarde voor opnieuw proberen is verstreken, wordt uw aanvraag niet verwerkt en wordt er een nieuwe waarde voor opnieuw proberen geretourneerd. Zie Beperking Resource Manager aanvragen voor meer informatie over beperkingslimieten.
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Feedback-community van Azure.
Feedback
https://aka.ms/ContentUserFeedback.
Binnenkort beschikbaar: In de loop van 2024 zullen we GitHub-problemen geleidelijk uitfaseren als het feedbackmechanisme voor inhoud en deze vervangen door een nieuw feedbacksysteem. Zie voor meer informatie:Feedback verzenden en weergeven voor