Delen via


HPC-taken blijven hangen in de annuleringsmodus en nieuwe taken worden niet gestart

Dit artikel biedt een oplossing voor problemen met het uitvoeren van taken die vastzitten in de annuleringsmodus en nieuwe taken kunnen niet worden omgezet in de status van de uitvoering wanneer een Azure SQL database wordt gebruikt voor een externe HPC PACK-database.

Symptomen

Wanneer u de actieve taken annuleert, blijven ze hangen in de modus Annuleren en staan nieuwe verzonden taken nog steeds in de wachtrij terwijl er rekenknooppunten beschikbaar zijn om de taken uit te voeren. Het opnieuw opstarten van de knooppunten helpt niet.

Ondertussen bereikt de PaaS-database (Platform as a Service) 100%, en ziet u het volgende foutbericht in het HPC-scheduler-logboek:

De scheduler-server is bezet. De clientaanvraag kan nu niet worden verwerkt. Probeer het later nogmaals.

Oorzaak

Dit probleem treedt op omdat het hoofdknooppunt te veel stress heeft omdat de PaaS-database de prestatielimiet bereikt.

Oplossing

U kunt dit probleem oplossen door de DTU (Database Transaction Unit) te verhogen naar een hogere SKU voor de scheduler-database in Azure die overeenkomt met uw workload. De minimale initiƫle DTU die is vereist voor de HPC-scheduler-database is 100 DTU.

Verwijzingen

Zie Stap 1: de externe databases voorbereiden voor meer informatie.

Contacteer ons voor hulp

Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Feedback-community van Azure.