Notitie
Voor toegang tot deze pagina is autorisatie vereist. U kunt proberen u aan te melden of de directory te wijzigen.
Voor toegang tot deze pagina is autorisatie vereist. U kunt proberen de mappen te wijzigen.
Dit artikel bevat een oplossing voor een fout die optreedt wanneer u een Microsoft Graph API-aanvraag uitvoert om een B2B-gebruiker (Business-to-Business) op te halen met behulp van User Principal Name (UPN).
Symptomen
Wanneer u een Microsoft Graph API-aanvraag uitvoert om een B2B-gebruiker op te halen met behulp van UPN, kan er een fout optreden.
Voorbeeld van aanvraag:
https://graph.microsoft.com/v1.0/users/example_gmail.com#EXT#@example.onmicrosoft.com
Antwoordvoorbeeld:
{
"error": {
"code": "Request_ResourceNotFound",
"message": "Resource '<resource-id>' does not exist or one of its queried reference-property objects are not present.",
"innerError": {
"request-id": "<request-id>",
"date": "2019-12-05T23:55:40"
}
}
}
Oorzaak
Het probleem treedt op omdat het #
teken in de UPN wordt behandeld als een speciaal teken in de URL. Alles na de #
wordt als een fragment behandeld en wordt niet via het netwerk verstuurd.
Oplossing
U kunt dit probleem oplossen door het #
teken in de UPN te coderen als %23
.
Dit is de juiste aanvraagindeling:
https://graph.microsoft.com/v1.0/users/example_gmail.com%23EXT%23@example.onmicrosoft.com
Contacteer ons voor hulp
Als u vragen hebt of hulp nodig hebt, maak een ondersteuningsaanvraag of vraag de Azure-communityondersteuning. U kunt ook productfeedback verzenden naar de Azure-feedbackcommunity.