Delen via


Foutbericht wanneer de Report Server-service wordt gestart of wanneer u toegang probeert te krijgen tot de Reporting Services-website of Power BI Report Server: 'Sleutel is niet geldig voor gebruik in de opgegeven status'

Dit artikel helpt u bij het oplossen van het probleem dat optreedt wanneer u het serviceaccount van Report Server opnieuw instelt.

Oorspronkelijke productversie: SQL Server
Oorspronkelijk KB-nummer: 955757

Symptomen

Wanneer u werkt met een computer waarop Microsoft SQL Server wordt uitgevoerd, ontvangt u mogelijk het volgende foutbericht in het traceringslogboek van de rapportserverservice:

Er is een interne fout opgetreden op de rapportserver. Zie het foutenlogboek voor meer informatie. (rsInternalError) Online Help-sleutel ophalen die niet geldig is voor gebruik in de opgegeven status. (Uitzondering van HRESULT: 0x8009000B)

Mogelijk ontvangt u dit foutbericht wanneer een van de volgende acties wordt uitgevoerd:

  • De Report Server-service wordt gestart.
  • U probeert toegang te krijgen tot de Reporting Services-website.

Bovendien ontvangt u mogelijk het volgende foutbericht in het traceringslogboek van de rapportserverservice:

FOUT: Er is een uitzondering opgetreden tijdens het starten van de service.

Fout: Microsoft.ReportingServices.Diagnostics.Utilities.ReportServerDisabledException: de rapportserver kan de symmetrische sleutel die wordt gebruikt voor toegang tot gevoelige of versleutelde gegevens in een rapportserverdatabase niet ontsleutelen. U moet een back-upsleutel herstellen of alle versleutelde inhoud verwijderen. Raadpleeg de documentatie voor meer informatie.

Oorzaak

Dit probleem treedt meestal op wanneer het wachtwoord van het rapportserverserviceaccount opnieuw wordt ingesteld.

Oplossing

U kunt dit probleem op een van de volgende manieren oplossen:

Methode 1: De symmetrische sleutel herstellen

Notitie

Als u deze methode wilt gebruiken, moet er een back-upkopie van de symmetrische sleutel beschikbaar zijn.

Voer de volgende stappen uit om de symmetrische sleutel te herstellen:

  1. Start het hulpprogramma Reporting Services-configuratie en maak vervolgens verbinding met de rapportserver die u wilt configureren.
  2. Klik op de pagina Versleutelingssleutels op Herstellen.
  3. Klik op het .snk-bestand dat de back-upkopie bevat.
  4. Typ het wachtwoord waarmee het bestand wordt ontgrendeld.
  5. Klik op OK.

Methode 2: De versleutelde inhoud verwijderen

Belangrijk

Met deze methode worden alle versleutelde inhoud verwijderd. Dit omvat verbindingsreeks s en opgeslagen referenties. Vervolgens maakt deze methode een nieuwe symmetrische sleutel. Gebruik deze methode alleen als u de symmetrische sleutel niet kunt herstellen.

Nadat u de versleutelde inhoud hebt verwijderd, moet u de ontbrekende verbindingsreeks s en de ontbrekende opgeslagen referenties in de rapporten en in de gedeelde gegevensbronnen die deze waarden niet meer hebben, opnieuw invoeren. Daarnaast moet u alle abonnementen bijwerken die gebruikmaken van leveringsextensies die versleutelde gegevens opslaan. Dit omvat de bezorgingsextensie voor bestandsshares en elke externe leveringsextensie die versleutelde waarden gebruikt.

Er is geen geautomatiseerde manier om deze informatie bij te werken. U moet elk rapport, elk abonnement en elke gedeelde gegevensbron die gebruikmaakt van opgeslagen referenties en verbindingsreeks één voor één bijwerken.

Voer de volgende stappen uit om de versleutelde inhoud te verwijderen:

  1. Start het hulpprogramma Reporting Services-configuratie en maak vervolgens verbinding met de rapportserver die u wilt configureren.
  2. Klik op de pagina Versleutelingssleutels op Versleutelde inhoud verwijderen.

Verwijzingen