Delen via


NMI_HARDWARE_FAILURE fout wanneer een NMI wordt geactiveerd in Windows

In dit artikel wordt een standaardgedrag besproken waarbij de NMI_HARDWARE_FAILURE fout optreedt wanneer een niet-maskerbare interrupt (NMI) wordt geactiveerd.

Van toepassing op: Windows 10 - alle edities, Windows Server 2012 R2
Origineel KB-nummer: 2750146

Symptomen

Op een Windows-computer kan een NMI worden geactiveerd door een gebruiker die handmatig op een NMI-switch op de computer drukt of vanwege een hardwarefout.

In dit geval stopt Windows met uitvoeren en wordt een blauw scherm weergegeven met de melding 'Uw pc heeft een probleem gelopen en moet opnieuw worden opgestart'. Deze bevat de volgende foutcode: NMI_HARDWARE_FAILURE.

De computer kan vervolgens een geheugendumpbestand opslaan en automatisch opnieuw opstarten, afhankelijk van de instellingen die zijn opgegeven onder 'Opstarten en herstel' in de 'Geavanceerde systeeminstellingen' onder het configuratiescherm van het systeem.

Oorzaak

Het gedrag wanneer een NMI wordt aangetroffen, is gewijzigd in vergelijking met eerdere versies van Windows. In Windows 7, Windows Server 2008 R2 en eerdere versies was het antwoord wanneer het systeem een NMI aantrof afhankelijk van de configuratie van de registerwaarde 'NMICrashDump'. Voor meer informatie over de NMICrashDump-registerwaarde en de verwerking van NMI's in eerdere Windows-versies, klikt u op het volgende artikelnummer om het artikel in de Microsoft Knowledge Base weer te geven:
927069 Een volledig crashdumpbestand of een kernelcrashdumpbestand genereren met behulp van een NMI op een Windows-systeem

In Windows 8 en Windows Server 2012 kan dit gedrag niet worden geconfigureerd. Een NMI resulteert altijd in een bugcontrole 0x80 (NMI_HARDWARE_FAILURE). Dit komt overeen met het gedrag in eerdere Windows-versies waarin de registerwaarde 'NMICrashDump' aanwezig was en is ingesteld op een waarde van 1.

Meer informatie

Dit gedrag is inherent aan het ontwerp van het product.