Notitie
Voor toegang tot deze pagina is autorisatie vereist. U kunt proberen u aan te melden of de directory te wijzigen.
Voor toegang tot deze pagina is autorisatie vereist. U kunt proberen de mappen te wijzigen.
Dit artikel helpt u bij het oplossen van een probleem dat optreedt wanneer .NET Framework 4.x-toepassingen vergelijken Japanse tekenreeksen.
Van toepassing op: Windows 10 versie 2004, Windows 10 versie 20H2, Windows 10 versie 21H1, Windows 10 versie 21H2, Windows 10 versie 22H2
Symptomen
Bepaalde Japanse tekens met halve breedte en katakana en Hiragana-tekens met een medevoegteken worden niet geïnterpreteerd als hetzelfde teken. Wanneer u de CompareInfo.IndexOf
methode en de of IgnoreWidth
opties IgnoreKanaType
CompareOptions
gebruikt om een vergelijking te maken, worden deze tekens als verschillend geëvalueerd vanwege een probleem in de sorteerregel.
Oorzaak
Vanaf versie 2004 heeft Windows 10 de versie van National Language Support (NLS) bijgewerkt naar 6.3 en ondersteuning toegevoegd voor Arabisch en Hebreeuws. Deze toevoeging is van invloed op de regels voor het sorteren van Japanse tekenreeksvergelijkingen die NLS gebruiken, zodat de vergelijkingen verschillende resultaten opleveren.
Tijdelijke oplossing
Waarschuwing
Als u het register onjuist bewerkt, kunnen er grote problemen optreden. Deze problemen kunnen ertoe leiden dat u het besturingssysteem opnieuw moet installeren of zelfs kunt voorkomen dat uw computer wordt gestart. Microsoft kan niet garanderen dat deze problemen kunnen worden opgelost. Maak een back-up van het register voor herstel in geval van problemen voordat u het wijzigt. Het wijzigen van het register is voor eigen risico.
Oplossing 1
Zet de NLS-sorteerregel terug naar versie 6.2. Deze versie wordt gebruikt in Windows 10, versie 1909 en eerdere versies. Wanneer u gegevens tussen systemen moet delen, kunt u overwegen om de tijdelijke oplossing consistent toe te passen. Als u deze tijdelijke oplossing gebruikt, voert u voldoende tests en evaluaties uit om problemen te beperken die worden veroorzaakt door verschillende sorteerregelversies op meerdere systemen.
Volg deze stappen om deze tijdelijke oplossing te gebruiken:
Open een opdrachtpromptvenster (cmd.exe) als beheerder.
Voer de volgende opdracht uit:
reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\Sorting\Versions /ve /d 0006020F /f
Start de computer of processen opnieuw op om het volledige effect te zien.
Belangrijk
Als u KB4586853 of een latere update op de computer niet hebt geïnstalleerd, kan het instellen van een ongeldige waarde in deze registervermelding verhinderen dat de computer wordt gestart.
Oplossing 2
Stel de NLS-sorteerregel in op versie 6.4. Deze versie wordt gebruikt in Windows 11. Hiervoor moet u KB5014023 of een latere update toepassen en de versie upgraden naar versie 1741 of een latere versie. In dit geval wordt versie 22H2 al toegepast en hoeft deze niet te worden bijgewerkt.
Pas KB5014023 of een latere update toe voor Windows 10-versies 2004, 20H2, 21H1 en 21H2.
Open het opdrachtpromptvenster (cmd.exe) als beheerder.
Voer de volgende opdracht uit:
reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Nls\Sorting\Versions /ve /d 00060403 /f
Start de computer of processen opnieuw op om het volledige effect te zien.