Atrybut MailNickName lub Alias w Exchange Online jest niezgodny z tym, co jest ustawione w lokalnym programie Exchange

Symptomy

Atrybut Alias lub Mailnickname w Microsoft Exchange Online nie jest zgodny z tym, co jest ustawione w środowisku lokalnym programu Exchange dla zsynchronizowanego konta użytkownika.

Przyczyna

Ten problem występuje, jeśli zostaną wprowadzone zmiany głównej nazwy użytkownika (UPN) dla użytkownika, a wartość atrybutu Mailnickname zostanie zmieniona na prefiks nazwy UPN.

Rozwiązanie

Aby rozwiązać ten problem, zaktualizuj Alias atrybut lub Mailnickname . Aby to zrobić, należy skorzystać z jednej z następujących metod.

Metoda 1. Używanie powłoki zarządzania programu Exchange

  1. Zmień istniejącą Alias wartość atrybutu tak, aby zmiana została odnaleziona przez Microsoft Entra Connect. Ta zmiana powinna zostać zsynchronizowana z platformą Microsoft 365. W tym celu użyj Set-Mailbox polecenia cmdlet lub Set-RemoteMailbox na podstawie typu adresata w lokalnej aplikacji Exchange.

    • Set-RemoteMailbox

      $alias=Get-remotemailbox <user@domain.com>
      Set-RemoteMailbox <user@domain.com> -alias "$($alias.alias)1"
      
    • Set-Mailbox

      $alias=Get-mailbox <user@domain.com>
      Set-Mailbox <user@domain.com> -alias "$($alias.alias)1"**
      
  2. Uruchom synchronizację różnicową z programu Microsoft Entra Connect lub poczekaj, aż Microsoft Entra Connect uruchomi różnicę. Najlepiej jest zsynchronizować zmiany wprowadzone w kroku 1 z platformą Microsoft 365.

  3. Zmień wartość atrybutu na Alias jego oryginalną wartość. W tym celu uruchom jedno z następujących poleceń cmdlet:

    Set-RemoteMailbox <user@domain.com> -alias "$($alias.alias)"
    
    Set-Mailbox <user@domain> -alias "$($alias.alias)"
    
  4. Rozpocznij synchronizację delty z programu Microsoft Entra Connect lub poczekaj, aż Microsoft Entra Connect uruchomi różnicę> Najlepiej, aby zsynchronizować zmiany z platformą Microsoft 365.

Metoda 2. Korzystanie z modułu programu PowerShell usługi Active Directory

  1. Zmień wartość atrybutu Mailnickname tak, aby zmiana została odnaleziona przez Microsoft Entra Connect. Ta zmiana powinna zostać zsynchronizowana z platformą Microsoft 365. W tym celu uruchom następujący zestaw poleceń cmdlet:

    $mailnickname=Get-ADUser -Properties * -Filter {name -like '<username>*'}
    Get-ADUser -Properties * -Filter {name -like '<username>*'} | set-aduser -replace @{mailnickname="$($mailnickname.mailnickname)1"
    
  2. Uruchom synchronizację różnicową z programu Microsoft Entra Connect lub poczekaj, aż Microsoft Entra Connect uruchomi różnicę. Najlepiej jest zsynchronizować zmiany wprowadzone w kroku 1 z platformą Microsoft 365.

  3. Zmień wartość atrybutu na Mailnickname jego oryginalną wartość. W tym celu uruchom następujące polecenie cmdlet:

    Get-ADUser -Properties * -Filter {name -like '<username>*'} | set-aduser -replace @{mailnickname="$($mailnickname.mailnickname)"
    
  4. Uruchom synchronizację różnicową z programu Microsoft Entra Connect lub poczekaj, aż Microsoft Entra Connect uruchomi różnicę. Najlepiej jest zsynchronizować zmiany wprowadzone w kroku 1 z platformą Microsoft 365.