UnknownIncomingEmailIntegrationError — wyjątek 2147220956 pojawia się w ramach alertu synchronizacji Server-Side w usłudze Microsoft Dynamics 365
Ten artykuł zawiera rozwiązanie błędu występującego w rekordzie skrzynki pocztowej Dynamics 365 firmy Microsoft.
Dotyczy: Microsoft Dynamics 365
Oryginalny numer KB: 4471762
Symptomy
W rekordzie skrzynki pocztowej Dynamics 365 pojawia się alert poziomu ostrzeżenia, taki jak następująca wiadomość:
"Wystąpił nieznany błąd podczas odbierania wiadomości e-mail za pośrednictwem skrzynki pocztowej "[Nazwa skrzynki pocztowej] ". Właściciel skojarzonego profilu serwera poczty e-mail [Nazwa profilu] został powiadomiony. System spróbuje później ponownie otrzymać wiadomość e-mail.
kod błędu serwera Email: serwer exchange zwrócił wyjątek UnknownIncomingEmailIntegrationError -2147220956".
Przyczyna
Kod błędu — 2147220956 wskazuje błąd IsvUnexpected. Co zwykle wskazuje, że niestandardowa wtyczka lub przepływ pracy zgłasza błąd i powoduje niepowodzenie tworzenia elementu.
Rozwiązanie
W poniższych krokach użyto przykładu rekordu wiadomości e-mail, którego nie można utworzyć. Jeśli ten błąd jest rejestrowany dla innego typu elementu, takiego jak Termin, Kontakt lub Zadanie, ten sam typ kroków można zastosować, zastępując odwołania do wiadomości e-mail typem rekordu, którego dotyczy rozwiązywanie problemów.
Sprawdź, czy masz jakieś niestandardowe wtyczki lub przepływy pracy, które są uruchamiane synchronicznie podczas tworzenia wiadomości e-mail. Jeśli wtyczka lub przepływ pracy powoduje błąd, Server-Side Synchronizacja nie utworzy wiadomości e-mail. Poniższe kroki mogą pomóc w określeniu, czy istnieją jakiekolwiek przepływy pracy lub wtyczki w organizacji, które są uruchamiane podczas tworzenia wiadomości e-mail:
Przepływu pracy
W Dynamics 365 aplikacji internetowej przejdź do pozycji Ustawienia, a następnie wybierz pozycję Procesy.
Zmień widok na Aktywowane procesy.
Sortuj w kolumnie Jednostka podstawowa i poszukaj wierszy z Email jako jednostką podstawową i przepływem pracy jako kategorią.
Zamiast tego można użyć opcji filtrowania w siatce, aby filtrować według kategorii = przepływ pracy i jednostka podstawowa = Email
Otwórz każdy znaleziony przepływ pracy, który spełnia powyższe kryteria (jeśli istnieje).
Jeśli wybrano opcję Rozpocznij poutworzeniu rekordu , a opcja Uruchom ten przepływ pracy w tle (zalecane) nie jest zaznaczona, przyczyną może być ten przepływ pracy.
Uwaga
Jeśli rozwiązujesz problemy z tym typem błędu za pomocą terminu, kontaktu lub zadania, sprawdź również, czy przepływ pracy jest skonfigurowany do uruchamiania podczas aktualizacji tego typu rekordu.
Wybierz sekcję Sesje procesu po lewej stronie i poszukaj wszelkich błędów związanych z wiadomością e-mail, która nie została pomyślnie utworzona.
Wtyczki
- W Dynamics 365 aplikacji internetowej przejdź do pozycji Ustawienia,Dostosowania, a następnie wybierz pozycję Dostosuj system.
- Wybierz pozycję Kroki przetwarzania komunikatów zestawu Sdk.
- Sortuj według kolumny Kod typu obiektu podstawowego (filtr SdkMessage) i poszukaj wierszy dla jednostki Email.
- Jeśli znajdziesz wiersze, a tryb wykonywania jest synchroniczny, może to potencjalnie zakłócać tworzenie wiadomości e-mail.
Jeśli problem jest stale odtwarzany i można tymczasowo wyłączyć przepływ pracy lub wtyczkę jako test, co może pozwolić określić, czy przyczyną jest przepływ pracy lub wtyczka.
Opinia
https://aka.ms/ContentUserFeedback.
Dostępne już wkrótce: W 2024 r. będziemy stopniowo wycofywać zgłoszenia z serwisu GitHub jako mechanizm przesyłania opinii na temat zawartości i zastępować go nowym systemem opinii. Aby uzyskać więcej informacji, sprawdź:Prześlij i wyświetl opinię dla