Udostępnij za pośrednictwem


Rozwiązywanie problemów z kopiowaniem danych w usłudze Azure Data Box Disk

Ten artykuł dotyczy urządzenia Microsoft Azure Data Box Disk i opisuje sposób rozwiązywania wszelkich problemów występujących podczas kopiowania danych na dyski. W tym artykule opisano również problemy występujące podczas korzystania z narzędzia do kopiowania podzielonego.

Problemy z kopiowaniem danych podczas korzystania z systemu Linux

W tej sekcji szczegółowo omówiono niektóre najważniejsze problemy występujące podczas korzystania z klienta systemu Linux do kopiowania danych na dyski.

Problem: Dysk jest instalowany jako tylko do odczytu

Przyczyna

Nieczysty system plików może spowodować, że dyski są instalowane jako tylko do odczytu.

Ponowne instalowanie dysku jako odczytu i zapisu nie działa z urządzeniami Data Box Disk. Ten scenariusz nie jest obsługiwany w przypadku dysków odszyfrowanych przez funkcję dislocker. Możesz pomyślnie ponownie zainstalować urządzenie przy użyciu następującego polecenia:

# mount -o remount, rw /mnt/DataBoxDisk/mountVol1

Mimo że ponowne instalowanie zakończyło się pomyślnie, dane nie będą utrwalane.

Rozwiązanie

Wykonaj następujące kroki w systemie Linux:

  1. ntfsprogs Zainstaluj pakiet dla narzędzia ntfsfix.

  2. Odinstalowywanie punktów instalacji udostępnionych dla dysku przez narzędzie odblokowywania. Liczba punktów instalacji różni się w zależności od dysków.

    unmount /mnt/DataBoxDisk/mountVol1
    
  3. Uruchom polecenie ntfsfix w odpowiedniej ścieżce. Wyróżniona liczba powinna być taka sama jak w kroku 2.

    ntfsfix /mnt/DataBoxDisk/bitlockerVol1/dislocker-file
    
  4. Uruchom następujące polecenie, aby usunąć metadane hibernacji, które mogą powodować problem z instalacją.

    ntfs-3g -o remove_hiberfile /mnt/DataBoxDisk/bitlockerVol1/dislocker-file /mnt/DataBoxDisk/mountVol1
    
  5. Wykonaj czystą instalację.

    ./DataBoxDiskUnlock_x86_64 /unmount
    
  6. Odblokuj i zainstaluj czystą instalację.

  7. Przetestuj punkt instalacji, zapisując plik.

  8. Odinstalowywanie i ponowne odinstalowywanie w celu zweryfikowania trwałości pliku.

  9. Kontynuuj kopiowanie danych.

Problem: Błąd polegający na tym, że dane nie są utrwalane po skopiowaniu

Przyczyna

Jeśli dysk nie zawiera skopiowanych danych po zainstalowaniu, możliwe jest, że został on zainstalowany jako odczyt-zapis po zainstalowaniu jako tylko do odczytu.

Rozwiązanie

Jeśli tak jest, zobacz rozdzielczość dysków instalowanych jako tylko do odczytu.

Jeśli tak nie było, skopiuj dzienniki z folderu, który ma narzędzie do odblokowywania dysków Data Box Disk i skontaktuj się z pomoc techniczna firmy Microsoft.

Błędy narzędzia do dzielenia skopiowanych dysków Data Box Disk

Problemy występujące podczas używania narzędzia do dzielenia kopii w celu podzielenia danych na wiele dysków zostały podsumowane w poniższej tabeli.

Komunikat o błędzie/ostrzeżenia Zalecenia
[Informacje] Pobieranie hasła funkcji BitLocker dla woluminu: m
[Błąd] Wyjątek przechwycony podczas pobierania klucza funkcji BitLocker dla woluminu m:
Sekwencja nie zawiera elementów.
Ten błąd jest zgłaszany, jeśli docelowe dyski Data Box Disk są w trybie offline.
W przypadku dysków w trybie online należy użyć narzędzia diskmgmt.msc.
[Błąd] Zgłoszono wyjątek: operacja usługi WMI zakończyła się niepowodzeniem:
Method=UnlockWithNumericalPassword, ReturnValue=2150694965,
Win32Message = format podanego hasła odzyskiwania jest nieprawidłowy.
Hasła odzyskiwania funkcji BitLocker są 48-cyfrowe.
Sprawdź, czy hasło odzyskiwania ma poprawny format, a następnie spróbuj ponownie.
Użyj narzędzia do odblokowywania dysków Data Box Disk, aby odblokować dyski i ponowić próbę wykonania polecenia. Aby uzyskać więcej informacji, przejdź do strony
  • Odblokuj urządzenie Data Box Disk.
  • Odblokowywanie dysków
  • [Błąd] Zgłoszono wyjątek: plik DriveManifest.xml znajduje się na dysku docelowym.
    Oznacza to, że dysk docelowy został prawdopodobnie przygotowany przy użyciu innego pliku dziennika.
    Aby dodać więcej danych do tego samego dysku, użyj poprzedniego pliku dziennika. Aby usunąć istniejące dane i ponownie użyć dysku docelowego dla nowego zadania importu, usuń DriveManifest.xml na dysku. Ponownie uruchom to polecenie, używając nowego pliku dziennika.
    Ten błąd jest wyświetlany podczas próby użycia tego samego zestawu dysków dla wielu sesji importu.
    Z jedną sesją dzielenia i kopiowania można użyć tylko jednego zestawu dysków.
    [Błąd] Zgłoszono wyjątek: CopySessionId importdata-sept-test-1 odwołuje się do poprzedniej sesji kopiowania i nie może zostać użyty ponownie w nowej sesji kopiowania. Ten błąd jest zgłaszany w przypadku próby użycia tej samej nazwy zadania dla nowego zadania, które zostało poprzednio pomyślnie ukończone.
    Należy przypisać unikatową nazwę dla nowego zadania.
    [Informacje] Nazwa pliku lub katalogu docelowego przekracza limit długości dla systemu plików NTFS. Ten komunikat jest zgłaszany, gdy nazwa pliku docelowego została zmieniona z powodu długiej ścieżki pliku.
    Aby sterować tym zachowaniem, należy zmodyfikować opcję dyspozycji w pliku config.json.
    [Błąd] Zgłoszono wyjątek: nieprawidłowa sekwencja ucieczki pliku JSON. Ten komunikat jest zgłaszany, gdy format pliku config.json jest nieprawidłowy.
    Przed zapisaniem pliku config.json zweryfikuj go przy użyciu narzędzia JSONlint.

    Następne kroki

    • Dowiedz się, jak rozwiązywać problemy z narzędziem do sprawdzania poprawności.