Rozwiązywanie typowych problemów w usłudze AKS Edge Essentials
W tym artykule opisano sposób znajdowania rozwiązań problemów występujących podczas korzystania z usługi AKS Edge Essentials. Znane problemy i błędy są zorganizowane według obszaru funkcjonalnego. Możesz użyć linków podanych w tym artykule, aby znaleźć rozwiązania i obejścia, aby je rozwiązać.
Otwieranie wniosku o pomoc techniczną
Zobacz artykuł Uzyskiwanie pomocy technicznej, aby uzyskać informacje o sposobie korzystania z witryny Azure Portal w celu uzyskania pomocy technicznej lub otwarcia wniosku o pomoc techniczną dla usługi AKS Edge Essentials.
Problemy z wdrażaniem
Problem z niezaufanym wydawcą
Komunikat o błędzie: "Czy chcesz uruchomić oprogramowanie od tego niezaufanego wydawcy? ....."
Obejście: Zaktualizuj zasady wykonywania programu PowerShell na RemoteSigned:
# Get the execution policy on the system
Get-ExecutionPolicy
# Set the execution policy for this process only
if ((Get-ExecutionPolicy) -ne "RemoteSigned") { Set-ExecutionPolicy -ExecutionPolicy RemoteSigned -Scope Process -Force }
Mała ilość miejsca na dysku powoduje usunięcie wcześniej buforowanych obrazów kontenerów
Gdy węzeł zabraknie miejsca na dysku, niektóre wstępnie załadowane obrazy są bezużyteczne zbierane przez containerd
środowisko uruchomieniowe. W takim przypadku najpierw zwolnij trochę miejsca na dysku, a następnie uruchom następujące polecenie, aby ponownie ściągnąć buforowane obrazy:
Invoke-AksEdgeNodeCommand -NodeType Linux -command "sudo /path/to/script/reimport-ci.sh
Ten skrypt sprawdza brakujące obrazy i w razie potrzeby ponownie je zaimportuje.
Łączność z usługą Azure Arc
Problem:
Disconnect-AksEdgeArc
nie usuwa zasobników z klastra.Obejście: Jeśli zasobniki nie są czyszczone, uruchom następujące polecenia, aby ręcznie wyczyścić istniejące zasoby związane z usługą Azure Arc, zanim spróbuj ponownie nawiązać połączenie:
kubectl delete ns azure-arc kubectl delete clusterrolebinding azure-arc-operator kubectl delete secret sh.helm.release.v1.azure-arc.v1
Problem: Łączność z usługą Azure Arc nie działa w środowisku serwera proxy.
Obejście: Ustawienia serwera proxy dla całego systemu można włączyć, wykonując następujące opcje > > internetowe Ustawienia sieci LAN.
Wdrożenia w trybie offline
Nie można pobrać certyfikatu nodeagent: Nie znaleziono
Sprawdź konfigurację karty sieciowej. Podczas wdrażania usługa AKS Edge Essentials wymaga karty, która jest włączona i ma poprawny adres IP, podsieć i bramę domyślną. Te wartości są wypełniane automatycznie w środowisku DHCP. Jeśli ustawisz ręcznie, upewnij się, że wszystkie trzy zostały ustawione. W wielu przypadkach brama domyślna nie jest ustawiona, co powoduje wystąpienie tego błędu.
Kubernetes
Zasobnik Kube-vip stale uruchamia się ponownie
W niektórych scenariuszach zasobnik kube-vip zapętla się i stale uruchamia ponownie.
Walidacja
Aby potwierdzić, że napotkany scenariusz dotyczy tego samego problemu opisanego w tym artykule, sprawdź, czy zasobnik kube-vip w przestrzeni nazw kube-system ma dużą liczbę ponownych uruchomień, uruchamiając następujące polecenie:
kubectl get pods –n kube-system
Przyczyna
Istnieje kilka różnych powodów, dla których zasobnik kube-vip może być stale uruchamiany ponownie. Oto następujące przyczyny:
- Używanie dysku systemu operacyjnego, który nie jest wspierany z dyskiem SSD lub dyskiem SSD w warstwie Premium podczas korzystania z maszyny wirtualnej platformy Azure. Wymagania sprzętowe można przejrzeć tutaj.
- Opóźnienie dysku jest zbyt wysokie. Jeśli opóźnienie dysku jest większe niż 10 ms, może to spowodować przekroczenie limitu czasu żądania, utratę lidera i potencjalną niestabilność klastra. Możesz przejrzeć wymagania sprzętowe itp., tutaj.
Rozwiązanie
Aby rozwiązać ten problem, przejrzyj podstawową infrastrukturę magazynu, aby upewnić się, że spełnia ona wymagania dotyczące wydajności itp. i AKS Edge Essentials. Rozważ również użycie magazynu opartego na dyskach SSD w warstwie Premium lub zoptymalizowanie konfiguracji magazynu pod kątem wydajności.