Udostępnij za pośrednictwem


Scenariusz: błąd odmowy uprawnień podczas próby utworzenia tabeli Apache Hive w usłudze Azure HDInsight

W tym artykule opisano kroki rozwiązywania problemów i możliwe rozwiązania problemów podczas korzystania z składników Interactive Query w klastrach usługi Azure HDInsight.

Problem

Podczas próby utworzenia tabeli zostanie wyświetlony następujący błąd:

java.sql.SQLException: Error while compiling statement: FAILED: HiveAccessControlException Permission denied: user [hdiuser] does not have [ALL] privilege on [wasbs://data@xxxxx.blob.core.windows.net/path/table]

W przypadku uruchomienia następującego polecenia magazynu HDFS zostanie wyświetlony podobny komunikat o błędzie:

hdfs dfs -mkdir wasbs://data@xxxxx.blob.core.windows.net/path/table

Przyczyna

Możliwość utworzenia tabeli w usłudze Apache Hive jest podejmowana przez uprawnienia zastosowane do konta magazynu klastra. Jeśli uprawnienia konta magazynu klastra są niepoprawne, nie będzie można tworzyć tabel. Ten błąd oznacza, że w przypadku tworzenia tabel można mieć poprawne zasady ranger i nadal występują błędy "Odmowa uprawnień".

Rozwiązanie

Ten błąd jest spowodowany brakiem wystarczających uprawnień do używanego kontenera magazynu. Użytkownik tworzący tabelę Hive musi mieć uprawnienia do odczytu, zapisu i wykonywania względem kontenera.

Następne kroki

Jeśli nie widzisz problemu lub nie możesz rozwiązać problemu, odwiedź jeden z następujących kanałów, aby uzyskać więcej pomocy technicznej:

  • Uzyskaj odpowiedzi od ekspertów platformy Azure za pośrednictwem pomocy technicznej społeczności platformy Azure.

  • Połącz się z @AzureSupport — oficjalne konto platformy Microsoft Azure w celu poprawy jakości obsługi klienta. Łączenie społeczności platformy Azure z odpowiednimi zasobami: odpowiedziami, pomocą techniczną i ekspertami.

  • Jeśli potrzebujesz dodatkowej pomocy, możesz przesłać wniosek o pomoc techniczną z Azure Portal. Wybierz pozycję Pomoc techniczna na pasku menu lub otwórz centrum Pomoc i obsługa techniczna . Aby uzyskać bardziej szczegółowe informacje, zobacz Jak utworzyć żądanie pomoc techniczna platformy Azure. Dostęp do zarządzania subskrypcjami i rozliczeń jest dołączony do subskrypcji platformy Microsoft Azure, a pomoc techniczna jest udostępniana za pośrednictwem jednego z planów pomocy technicznej platformy Azure.