Udostępnij za pośrednictwem


Podczas tworzenia folderu publicznego nie znaleziono żadnych aktywnych skrzynek pocztowych folderów publicznych

Oryginalny numer KB: 2786607

Symptomy

Załóżmy, że tworzysz pierwszą skrzynkę pocztową folderu publicznego z parametrem HoldForMigration w Exchange Server 2013 lub Microsoft Exchange Server 2016. Wykonujesz jedną z następujących akcji w środowisku:

  • Próbujesz uzyskać dostęp do hierarchii folderów publicznych, uruchamiając Get-PublicFolder polecenie cmdlet w usłudze Exchange Management Shell (EMS) lub za pomocą Programu Exchange Administration Center (EAC).
  • Próbujesz utworzyć nowy folder publiczny na serwerze Exchange.

W tej sytuacji pojawia się następujący komunikat o błędzie:

Nie znaleziono aktywnych skrzynek pocztowych folderów publicznych. Dzieje się tak, gdy nie są aprowizowane żadne skrzynki pocztowe folderu publicznego lub są one aprowizowane w trybie HoldForMigration. Jeśli obecnie nie przeprowadzasz migracji, utwórz skrzynkę pocztową folderu publicznego.

Jest to przykładowy zrzut ekranu przedstawiający komunikat o błędzie w usłudze EMS:

Zrzut ekranu przedstawiający komunikat o błędzie w programie E M S.

Poniżej przedstawiono przykładowy zrzut ekranu przedstawiający komunikat o błędzie w usłudze EAC:

Zrzut ekranu przedstawiający komunikat o błędzie w języku E A C.

Uwaga

Skrzynka pocztowa folderu publicznego powinna zostać utworzona przy użyciu parametru HoldForMigration tylko w przypadku migracji ze starszych folderów publicznych do nowoczesnych folderów publicznych w Exchange Server 2013 r. lub Exchange Server 2016 r. Określenie parametru HoldForMigration blokuje hierarchię folderów publicznych w Exchange Server 2013 lub Exchange Server 2016, aby użytkownicy nie mogli tworzyć żadnych folderów publicznych do czasu ukończenia migracji.
Następujące polecenie programu Exchange PowerShell jest przykładem danych wyjściowych, których można użyć do sprawdzenia, czy pierwsza skrzynka pocztowa folderu publicznego została utworzona przy użyciu parametru HoldForMigration :

[PS] C:\>(Get-OrganizationConfig).RootPublicFolderMailbox
IsValid : True
CanUpdate : True
HierarchyMailboxGuid : dba08a32-d51f-4c21-ae31-8f7d678ccfb1
HierarchySmtpAddress :
LockedForMigration : True

Wartość True pola LockedForMigration wskazuje, że hierarchia folderów publicznych jest zablokowana.

Przyczyna

Ten problem występuje, ponieważ HoldForMigration parametr jest określony podczas tworzenia pierwszej skrzynki pocztowej folderu publicznego. Takie działanie jest celowe.

Rozwiązanie

Jeśli utworzono pierwszą skrzynkę pocztową folderu publicznego z parametrem HoldForMigration migracji starszych folderów publicznych, wykonaj migrację. Aby uzyskać więcej informacji na temat sposobu użycia parametru HoldForMigration do migracji folderów publicznych, zobacz Jak migrować foldery publiczne z programu Exchange Server 2010 z dodatkiem SP3 do Microsoft Exchange Server 2013 r.

Jeśli nie masz starszych folderów publicznych w organizacji i przypadkowo utworzono pierwszą skrzynkę pocztową folderu HoldForMigration publicznego z parametrem, musisz usunąć wszystkie skrzynki pocztowe folderów publicznych, które znajdują się w organizacji. Następnie należy utworzyć nową skrzynkę pocztową folderu publicznego bez określania parametru HoldForMigration . W tym celu użyj jednej z tych metod.

Metoda 1. Usuwanie skrzynki pocztowej folderu publicznego przy użyciu usługi EAC

  1. Przejdź do następującej witryny internetowej firmy Microsoft, aby otworzyć usługę EAC: Https://CASServerName/ecp.
  2. Zaloguj się do usługi EAC przy użyciu konta administratora.
  3. Wybierz pozycję Foldery publiczne, a następnie wybierz pozycję Skrzynki pocztowe folderu publicznego.
  4. Usuń wszystkie skrzynki pocztowe folderu publicznego typu hierarchii pomocniczej .
  5. Usuń skrzynkę pocztową folderu publicznego typu Hierarchia podstawowa .
  6. Wybierz ikonę Nowa skrzynka pocztowa folderu publicznego , aby utworzyć skrzynkę pocztową folderu publicznego.
  7. Nowa skrzynka pocztowa jest wyświetlana jako podstawowa skrzynka pocztowa hierarchii.

Metoda 2. Usuwanie skrzynki pocztowej folderu publicznego przy użyciu usługi EMS

  1. Uruchom następujące polecenie cmdlet, aby zwrócić i usunąć skrzynki pocztowe folderu publicznego o typie hierarchii pomocniczej :

    Get-Mailbox -PublicFolder | where {$_.IsRootPublicFolderMailbox -eq $False} | Remove-Mailbox -PublicFolder
    
  2. Uruchom następujące polecenie cmdlet, aby zwrócić i usunąć skrzynkę pocztową folderu publicznego typu Hierarchia podstawowa :

    Get-Mailbox -PublicFolder | where {$_.IsRootPublicFolderMailbox -eq $true} | Remove-Mailbox -PublicFolder
    
  3. Utwórz skrzynkę pocztową folderu publicznego bez określania parametru HoldForMigration , uruchamiając następujące polecenie cmdlet:

    New-Mailbox -PublicFolder -Database "Mailbox Database Name" -Name "Public Folder Mailbox Name"
    

Więcej informacji

Aby uzyskać więcej informacji na temat usuwania folderów publicznych w środowisku Exchange Server 2013, zobacz Jak usunąć foldery publiczne.

Aby uzyskać więcej informacji na temat parametru HoldForMigration , zobacz Ogólne informacje o poleceniu cmdlet New-Mailbox wraz z parametrem HoldForMigration.